x11-misc/xwallpaper: bump to 0.6.3
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 29 Feb 2020 21:05:20 +0000 (13:05 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 29 Feb 2020 21:06:38 +0000 (13:06 -0800)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
x11-misc/xwallpaper/Manifest
x11-misc/xwallpaper/xwallpaper-0.6.3.ebuild [new file with mode: 0644]

index 5cdecc2bf0f2564b2db09e1123a58f764aaaa77d..3d431b5458994c055c85e31dba8df0071e34949c 100644 (file)
@@ -1 +1,2 @@
 DIST xwallpaper-0.6.2.tar.xz 82600 BLAKE2B 2e2b1121fcc2481c4a1e3c78e357534b9609b4435c4364f22dbed78ee0de7c671d2044403c22d22b494a9c89efd17d843f32b296c863df3c0f5d7b3673ae361f SHA512 3713038ffe8fe1da117dc64db6e3c8642fe663473d1e9078963890fa08f21af6ace60e08773e23e6025fcf2116563e24c76d07a66ba02537b38aafa9ac99f395
+DIST xwallpaper-0.6.3.tar.xz 82780 BLAKE2B 485a8d65ae48ee33e22ee199e693268b94f88a38e4f9d56445eab68b2563422824a1dcf4ac4b73d37ae1e51820e1619dcc654f7b50ce889ca13f28d0273d03ae SHA512 8ec6159a44ad08e57c634b0fb6dcc5945fc855796cb4507126248dc1d6c7c406eec1412335828d358eb47d5b9085a2028508d3fd4af75e0767369a8cf40f36f8
diff --git a/x11-misc/xwallpaper/xwallpaper-0.6.3.ebuild b/x11-misc/xwallpaper/xwallpaper-0.6.3.ebuild
new file mode 100644 (file)
index 0000000..2b1e161
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+       SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="jpeg png seccomp xpm"
+
+RDEPEND="
+       x11-libs/pixman
+       x11-libs/xcb-util
+       x11-libs/xcb-util-image
+       jpeg? ( media-libs/libjpeg-turbo:= )
+       png? ( media-libs/libpng:0= )
+       seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+       xpm? ( x11-libs/libXpm )"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+src_configure() {
+       local myconf=(
+               $(use_with jpeg)
+               $(use_with png)
+               $(use_with seccomp)
+               $(use_with xpm)
+               --with-randr
+       )
+       econf "${myconf[@]}"
+}