app-emulation/docker-compose: Remove py2
authorMichał Górny <mgorny@gentoo.org>
Mon, 3 Feb 2020 20:41:49 +0000 (21:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 3 Feb 2020 20:46:00 +0000 (21:46 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-emulation/docker-compose/docker-compose-1.24.0.ebuild
app-emulation/docker-compose/docker-compose-1.24.1.ebuild
app-emulation/docker-compose/docker-compose-1.25.0-r1.ebuild
app-emulation/docker-compose/docker-compose-1.25.1.ebuild
app-emulation/docker-compose/docker-compose-1.25.2.ebuild
app-emulation/docker-compose/docker-compose-1.25.3.ebuild
app-emulation/docker-compose/docker-compose-1.25.4.ebuild

index 231ec1bd9f17230ac09ecab0810bd4f1f94223ec..3e0bfb04269c46a1642c4bc1de79dc3aa52b5b49 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
 
 inherit bash-completion-r1 distutils-r1
 
@@ -29,15 +29,11 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/requests-2.18.1[${PYTHON_USEDEP}]
        >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
        >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
 
 DEPEND="${RDEPEND}
        test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
-       <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+               <dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )"
 
 S="${WORKDIR}/compose-${PV}"
 
index 12ac42d6a1935d344e029ade26c784685ea7bd7a..b310d81c22b2e47402f93766dbaba04fc8ba9fe6 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
 
 inherit bash-completion-r1 distutils-r1
 
@@ -29,15 +29,11 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/requests-2.18.1[${PYTHON_USEDEP}]
        >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
        >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
 
 DEPEND="${RDEPEND}
        test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
-       <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+               <dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )"
 
 S="${WORKDIR}/compose-${PV}"
 
index a6f8868eab7b381e17792d7edc88da3049296556..ae28e4a89c37ec951b0e22672f654e28b515f7be 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
 
 inherit bash-completion-r1 distutils-r1
 
@@ -29,17 +29,11 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
        >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
        >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
 
 DEPEND="${RDEPEND}
        test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
-       <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+               <dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )"
 
 S="${WORKDIR}/compose-${PV}"
 
index 2c7c3fe978b13cd067c00f5320dcb462a97d7f8b..014701ba9c8b2010f9b04ca62937b6f21654b3fa 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
 
 inherit bash-completion-r1 distutils-r1
 
@@ -29,17 +29,11 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
        >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
        >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
 
 DEPEND="${RDEPEND}
        test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
-       <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+               <dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )"
 
 S="${WORKDIR}/compose-${PV}"
 
index 7bdd266df6a47a6fd5d4e6d339354421719ae53e..08fd06065eefd6894c387441198ad3449c735365 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
 
 inherit bash-completion-r1 distutils-r1
 
@@ -29,18 +29,12 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
        >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
        >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
 
 DEPEND="${RDEPEND}
        test? (
                <dev-python/pytest-4[${PYTHON_USEDEP}]
                dev-python/ddt[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
        )"
 
 S="${WORKDIR}/compose-${PV}"
index fa7ef8bfb516200f68e0d8f28975933566739dcd..90f18a6ef86763fb73534df1841b2b90a1b2f81b 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
 
 inherit bash-completion-r1 distutils-r1
 
@@ -29,18 +29,12 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
        >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
        >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
 
 DEPEND="${RDEPEND}
        test? (
                <dev-python/pytest-4[${PYTHON_USEDEP}]
                dev-python/ddt[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
        )"
 
 S="${WORKDIR}/compose-${PV}"
index c7b13e93e7af52111e6df113f56c06ac5b3c5429..7fd5d941ab54fb25a5fa2f2998541857beadf548 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
 DISTUTILS_USE_SETUPTOOLS=rdepend
 
 inherit bash-completion-r1 distutils-r1
@@ -30,18 +30,12 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
        >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
        >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
 
 DEPEND="${RDEPEND}
        test? (
                <dev-python/pytest-4[${PYTHON_USEDEP}]
                dev-python/ddt[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
        )"
 
 S="${WORKDIR}/compose-${PV}"