projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
539d0a3
)
dev-python/wheel: Port to py39
author
Michał Górny
<mgorny@gentoo.org>
Mon, 25 May 2020 20:16:50 +0000
(22:16 +0200)
committer
Michał Górny
<mgorny@gentoo.org>
Mon, 25 May 2020 20:30:05 +0000
(22:30 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/wheel/wheel-0.34.2.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/wheel/wheel-0.34.2.ebuild
b/dev-python/wheel/wheel-0.34.2.ebuild
index 0006226aeb7e91596c25b7187dc56d368431030b..80c4b19e4e1602626ad7b825ff27fc0e42e94dbd 100644
(file)
--- a/
dev-python/wheel/wheel-0.34.2.ebuild
+++ b/
dev-python/wheel/wheel-0.34.2.ebuild
@@
-4,7
+4,7
@@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8
,9
} pypy3 )
inherit distutils-r1 eutils
@@
-25,3
+25,8
@@
src_prepare() {
-i setup.cfg || die
distutils-r1_src_prepare
}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}