dev-python/pyside2: imported from leycec/raiagent
authorRick Farina <zerochaos@gentoo.org>
Fri, 22 May 2020 16:29:43 +0000 (12:29 -0400)
committerRick Farina <zerochaos@gentoo.org>
Fri, 22 May 2020 17:22:09 +0000 (13:22 -0400)
very slightly modified

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
dev-python/pyside2/Manifest [new file with mode: 0644]
dev-python/pyside2/metadata.xml [new file with mode: 0644]
dev-python/pyside2/pyside2-5.14.1-r2.ebuild [new file with mode: 0644]
dev-python/pyside2/pyside2-5.14.2.ebuild [new file with mode: 0644]

diff --git a/dev-python/pyside2/Manifest b/dev-python/pyside2/Manifest
new file mode 100644 (file)
index 0000000..a132526
--- /dev/null
@@ -0,0 +1,2 @@
+DIST pyside-setup-opensource-src-5.14.1.tar.xz 3217008 BLAKE2B c02a79ecea0ba8c7f5547d16c842437455f7f7fce9b7993849919b593fc50b70661e1fc7c1e01eb6a505807f05e17696b2e7727f6ada9ecae2ce30a9ab37a4aa SHA512 6dfe8dc6f302a35a6448c4facb2b98d638506381638c8bda69b75a47ea6cb3168b11515faf0000dbfb5e36bfad5d14488ba5a9bd914adb3f5c38ed18714521d4
+DIST pyside-setup-opensource-src-5.14.2.tar.xz 3238036 BLAKE2B 454f19ae4e154747bad2b833727ab62ded15bbac495cc0bef112ce6cccdd69bb5bb541c9b31125bd05090bfce042bac2ac8b47690c695e82b5c901e45e87f681 SHA512 6708c4ebb115119796756ccac89197e111eb27c4a91f52875da04eff4ca6f9e3fffefc18cc0219a8c3a3c81a667bf7509909a6d1d9ff1ee2cc0d957453cceffa
diff --git a/dev-python/pyside2/metadata.xml b/dev-python/pyside2/metadata.xml
new file mode 100644 (file)
index 0000000..5d37198
--- /dev/null
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>zerochaos@gentoo.org</email>
+               <name>Rick Farina</name>
+       </maintainer>
+       <use>
+               <flag name="3d">Build Qt3DCore, Qt3DAnimation, Qt3DExtras, Qt3DInput, Qt3DLogic, and Qt3DRender modules</flag>
+               <flag name="charts">Build QtCharts module</flag>
+               <flag name="concurrent">Build QtConcurrent module</flag>
+               <flag name="datavis">Build QtDataVisualization module</flag>
+               <flag name="designer">Build QtDesigner and QtUiTools modules</flag>
+               <flag name="gles2-only">Build QtGui "QOpenGL*" classes</flag>
+               <flag name="gui">Build QtGui module</flag>
+               <flag name="help">Build QtHelp module</flag>
+               <flag name="location">Build QtLocation module</flag>
+               <flag name="multimedia">Build QtMultimedia and QtMultimediaWidgets modules</flag>
+               <flag name="network">Build QtNetwork module</flag>
+               <flag name="positioning">Build QtPositioning module</flag>
+               <flag name="printsupport">Build QtPrintSupport module</flag>
+               <flag name="qml">Build QtQml module</flag>
+               <flag name="quick">Build QtQuick and QtQuickWidgets modules</flag>
+               <flag name="script">Build QtScript module</flag>
+               <flag name="scripttools">Build QtScriptTools module</flag>
+               <flag name="scxml">Build QtScxml module</flag>
+               <flag name="sensors">Build QtSensors module</flag>
+               <flag name="speech">Build QtTextToSpeech module</flag>
+               <flag name="sql">Build QtSql module</flag>
+               <flag name="svg">Build QtSvg module</flag>
+               <flag name="testlib">Build QtTest module</flag>
+               <flag name="webchannel">Build QtWebChannel module</flag>
+               <flag name="webengine">Build QtWebEngine and QtWebEngineWidgets modules</flag>
+               <flag name="websockets">Build QtWebSockets module</flag>
+               <flag name="widgets">Build QtWidgets module</flag>
+               <flag name="x11extras">Build QtX11Extras module</flag>
+               <flag name="xml">Build QtXml module</flag>
+               <flag name="xmlpatterns">Build QtXmlPatterns module</flag>
+       </use>
+</pkgmetadata>
diff --git a/dev-python/pyside2/pyside2-5.14.1-r2.ebuild b/dev-python/pyside2/pyside2-5.14.1-r2.ebuild
new file mode 100644 (file)
index 0000000..654c60a
--- /dev/null
@@ -0,0 +1,208 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# TODO: Add PyPy once officially supported. See also:
+#     https://bugreports.qt.io/browse/PYSIDE-535
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake-utils python-r1 virtualx
+
+# TODO: Add conditional support for "QtRemoteObjects" via a new "remoteobjects"
+# USE flag after an external "dev-qt/qtremoteobjects" package has been created.
+# TODO: Add conditional support for apidoc generation via a new "doc" USE flag.
+# Note that doing so requires the Qt source tree, sphinx, and graphviz. Once
+# ready, pass the ${QT_SRC_DIR} variable to cmake to enable this support.
+# TODO: Disable GLES support if the "gles2-only" USE flag is disabled. Note
+# that the "PySide2/QtGui/CMakeLists.txt" and
+# "PySide2/QtOpenGLFunctions/CMakeLists.txt" files test for GLES support by
+# testing whether the "Qt5::Gui" list property defined by
+# "/usr/lib64/cmake/Qt5Gui/Qt5GuiConfig.cmake" at "dev-qt/qtgui" installation
+# time contains the substring "opengles2". Since cmake does not permit
+# properties to be overridden from the command line, these files must instead
+# be conditionally patched to avoid these tests. An issue should be filed with
+# upstream requesting a CLI-settable variable to control this.
+
+MY_P=pyside-setup-opensource-src-${PV}
+
+DESCRIPTION="Python bindings for the Qt framework"
+HOMEPAGE="https://wiki.qt.io/PySide2"
+SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
+
+# See "sources/pyside2/PySide2/licensecomment.txt" for licensing details.
+LICENSE="|| ( GPL-2 GPL-3+ LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="
+       3d charts concurrent datavis designer gles2-only gui help location
+       multimedia network positioning printsupport qml quick script scripttools
+       scxml sensors speech sql svg test testlib webchannel webengine websockets
+       widgets x11extras xml xmlpatterns
+"
+
+# Manually reextract these requirements on version bumps by running the
+# following one-liner from within "${S}":
+#     $ grep 'set\(.*_deps' PySide2/Qt*/CMakeLists.txt
+# Note that the "designer" USE flag corresponds to the "Qt5UiTools" module.
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+       3d? ( gui network )
+       charts? ( widgets )
+       datavis? ( gui )
+       designer? ( widgets xml )
+       gles2-only? ( gui )
+       help? ( widgets )
+       location? ( positioning )
+       multimedia? ( gui network )
+       printsupport? ( widgets )
+       qml? ( gui network )
+       quick? ( qml )
+       scripttools? ( gui script widgets )
+       speech? ( multimedia )
+       sql? ( widgets )
+       svg? ( widgets )
+       testlib? ( widgets )
+       webengine? (
+               location quick
+               widgets? ( gui network printsupport webchannel )
+       )
+       websockets? ( network )
+       widgets? ( gui )
+       x11extras? ( gui )
+"
+
+#tests fail pretty bad and I'm not fixing them right now
+RESTRICT="test"
+
+# Minimal supported version of Qt.
+QT_PV="$(ver_cut 1-2):5"
+
+RDEPEND="${PYTHON_DEPS}
+       >=dev-python/shiboken2-${PV}[${PYTHON_USEDEP}]
+       3d? ( >=dev-qt/qt3d-${QT_PV}[qml?] )
+       charts? ( >=dev-qt/qtcharts-${QT_PV}[qml?] )
+       concurrent? ( >=dev-qt/qtconcurrent-${QT_PV} )
+       datavis? ( >=dev-qt/qtdatavis3d-${QT_PV}[qml?] )
+       designer? ( >=dev-qt/designer-${QT_PV} )
+       gui? ( >=dev-qt/qtgui-${QT_PV}[gles2-only?] )
+       help? ( >=dev-qt/qthelp-${QT_PV} )
+       location? ( >=dev-qt/qtlocation-${QT_PV} )
+       multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[qml?,widgets?] )
+       network? ( >=dev-qt/qtnetwork-${QT_PV} )
+       positioning? ( >=dev-qt/qtpositioning-${QT_PV}[qml?] )
+       printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
+       qml? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
+       script? ( >=dev-qt/qtscript-${QT_PV} )
+       scxml? ( >=dev-qt/qtscxml-${QT_PV} )
+       sensors? ( >=dev-qt/qtsensors-${QT_PV}[qml?] )
+       speech? ( >=dev-qt/qtspeech-${QT_PV} )
+       sql? ( >=dev-qt/qtsql-${QT_PV} )
+       svg? ( >=dev-qt/qtsvg-${QT_PV} )
+       testlib? ( >=dev-qt/qttest-${QT_PV} )
+       webchannel? ( >=dev-qt/qtwebchannel-${QT_PV}[qml?] )
+       webengine? ( >=dev-qt/qtwebengine-${QT_PV}[widgets?] )
+       websockets? ( >=dev-qt/qtwebsockets-${QT_PV}[qml?] )
+       widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
+       x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
+       xml? ( >=dev-qt/qtxml-${QT_PV} )
+       xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV}[qml?] )
+"
+DEPEND="${RDEPEND}
+       test? ( x11-misc/xvfb-run )
+"
+
+S=${WORKDIR}/${MY_P}/sources/pyside2
+
+src_configure() {
+       # See COLLECT_MODULE_IF_FOUND macros in CMakeLists.txt
+       local mycmakeargs=(
+               -DBUILD_TESTS=$(usex test)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DAnimation=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DCore=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DExtras=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DInput=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DLogic=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DRender=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Charts=$(usex !charts)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Concurrent=$(usex !concurrent)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5DataVisualization=$(usex !datavis)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Designer=$(usex !designer)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Gui=$(usex !gui)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Help=$(usex !help)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Location=$(usex !location)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Multimedia=$(usex !multimedia)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5MultimediaWidgets=$(usex !multimedia yes $(usex !widgets))
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Network=$(usex !network)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Positioning=$(usex !positioning)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5PrintSupport=$(usex !printsupport)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Qml=$(usex !qml)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Quick=$(usex !quick)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5QuickWidgets=$(usex !quick yes $(usex !widgets))
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Script=$(usex !script)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5ScriptTools=$(usex !scripttools)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Scxml=$(usex !scxml)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Sensors=$(usex !sensors)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5TextToSpeech=$(usex !speech)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Sql=$(usex !sql)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Svg=$(usex !svg)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Test=$(usex !testlib)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5UiTools=$(usex !designer)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebChannel=$(usex !webchannel)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngine=$(usex !webengine)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineCore=$(usex !webengine)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets=$(usex !webengine yes $(usex !widgets))
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebSockets=$(usex !websockets)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Widgets=$(usex !widgets)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5X11Extras=$(usex !x11extras)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Xml=$(usex !xml)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5XmlPatterns=$(usex !xmlpatterns)
+       )
+
+       pyside2_configure() {
+               local mycmakeargs=(
+                       "${mycmakeargs[@]}"
+                       -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+                       -DPYTHON_EXECUTABLE="${PYTHON}"
+                       -DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
+                       -DSHIBOKEN_PYTHON_SHARED_LIBRARY_SUFFIX="-${EPYTHON}"
+               )
+               cmake-utils_src_configure
+       }
+       python_foreach_impl pyside2_configure
+}
+
+src_compile() {
+       python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+       local -x PYTHONDONTWRITEBYTECODE
+       python_foreach_impl virtx cmake-utils_src_test
+}
+
+src_install() {
+       pyside2_install() {
+               cmake-utils_src_install
+               python_optimize
+
+               # Uniquify the shiboken2 pkgconfig dependency in the PySide2 pkgconfig
+               # file for the current Python target. See also:
+               #     https://github.com/leycec/raiagent/issues/73
+               sed -i -e 's~^Requires: shiboken2$~&-'${EPYTHON}'~' \
+                       "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}.pc || die
+
+               # Uniquify the PySide2 pkgconfig file for the current Python target,
+               # preserving an unversioned "pyside2.pc" file arbitrarily associated
+               # with the last Python target. (See the previously linked issue.)
+               cp "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+       }
+       python_foreach_impl pyside2_install
+
+       # CMakeLists.txt installs a "PySide2Targets-gentoo.cmake" file forcing
+       # downstream consumers (e.g., pyside2-tools) to target one
+       # "libpyside2-*.so" library linked to one Python interpreter. See also:
+       #     https://bugreports.qt.io/browse/PYSIDE-1053
+       #     https://github.com/leycec/raiagent/issues/74
+       sed -i -e 's~pyside2-python[[:digit:]]\+\.[[:digit:]]\+~pyside2${PYTHON_CONFIG_SUFFIX}~g' \
+               "${ED}/usr/$(get_libdir)/cmake/PySide2-${PV}/PySide2Targets-gentoo.cmake" || die
+}
diff --git a/dev-python/pyside2/pyside2-5.14.2.ebuild b/dev-python/pyside2/pyside2-5.14.2.ebuild
new file mode 100644 (file)
index 0000000..654c60a
--- /dev/null
@@ -0,0 +1,208 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# TODO: Add PyPy once officially supported. See also:
+#     https://bugreports.qt.io/browse/PYSIDE-535
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake-utils python-r1 virtualx
+
+# TODO: Add conditional support for "QtRemoteObjects" via a new "remoteobjects"
+# USE flag after an external "dev-qt/qtremoteobjects" package has been created.
+# TODO: Add conditional support for apidoc generation via a new "doc" USE flag.
+# Note that doing so requires the Qt source tree, sphinx, and graphviz. Once
+# ready, pass the ${QT_SRC_DIR} variable to cmake to enable this support.
+# TODO: Disable GLES support if the "gles2-only" USE flag is disabled. Note
+# that the "PySide2/QtGui/CMakeLists.txt" and
+# "PySide2/QtOpenGLFunctions/CMakeLists.txt" files test for GLES support by
+# testing whether the "Qt5::Gui" list property defined by
+# "/usr/lib64/cmake/Qt5Gui/Qt5GuiConfig.cmake" at "dev-qt/qtgui" installation
+# time contains the substring "opengles2". Since cmake does not permit
+# properties to be overridden from the command line, these files must instead
+# be conditionally patched to avoid these tests. An issue should be filed with
+# upstream requesting a CLI-settable variable to control this.
+
+MY_P=pyside-setup-opensource-src-${PV}
+
+DESCRIPTION="Python bindings for the Qt framework"
+HOMEPAGE="https://wiki.qt.io/PySide2"
+SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
+
+# See "sources/pyside2/PySide2/licensecomment.txt" for licensing details.
+LICENSE="|| ( GPL-2 GPL-3+ LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="
+       3d charts concurrent datavis designer gles2-only gui help location
+       multimedia network positioning printsupport qml quick script scripttools
+       scxml sensors speech sql svg test testlib webchannel webengine websockets
+       widgets x11extras xml xmlpatterns
+"
+
+# Manually reextract these requirements on version bumps by running the
+# following one-liner from within "${S}":
+#     $ grep 'set\(.*_deps' PySide2/Qt*/CMakeLists.txt
+# Note that the "designer" USE flag corresponds to the "Qt5UiTools" module.
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+       3d? ( gui network )
+       charts? ( widgets )
+       datavis? ( gui )
+       designer? ( widgets xml )
+       gles2-only? ( gui )
+       help? ( widgets )
+       location? ( positioning )
+       multimedia? ( gui network )
+       printsupport? ( widgets )
+       qml? ( gui network )
+       quick? ( qml )
+       scripttools? ( gui script widgets )
+       speech? ( multimedia )
+       sql? ( widgets )
+       svg? ( widgets )
+       testlib? ( widgets )
+       webengine? (
+               location quick
+               widgets? ( gui network printsupport webchannel )
+       )
+       websockets? ( network )
+       widgets? ( gui )
+       x11extras? ( gui )
+"
+
+#tests fail pretty bad and I'm not fixing them right now
+RESTRICT="test"
+
+# Minimal supported version of Qt.
+QT_PV="$(ver_cut 1-2):5"
+
+RDEPEND="${PYTHON_DEPS}
+       >=dev-python/shiboken2-${PV}[${PYTHON_USEDEP}]
+       3d? ( >=dev-qt/qt3d-${QT_PV}[qml?] )
+       charts? ( >=dev-qt/qtcharts-${QT_PV}[qml?] )
+       concurrent? ( >=dev-qt/qtconcurrent-${QT_PV} )
+       datavis? ( >=dev-qt/qtdatavis3d-${QT_PV}[qml?] )
+       designer? ( >=dev-qt/designer-${QT_PV} )
+       gui? ( >=dev-qt/qtgui-${QT_PV}[gles2-only?] )
+       help? ( >=dev-qt/qthelp-${QT_PV} )
+       location? ( >=dev-qt/qtlocation-${QT_PV} )
+       multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[qml?,widgets?] )
+       network? ( >=dev-qt/qtnetwork-${QT_PV} )
+       positioning? ( >=dev-qt/qtpositioning-${QT_PV}[qml?] )
+       printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
+       qml? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
+       script? ( >=dev-qt/qtscript-${QT_PV} )
+       scxml? ( >=dev-qt/qtscxml-${QT_PV} )
+       sensors? ( >=dev-qt/qtsensors-${QT_PV}[qml?] )
+       speech? ( >=dev-qt/qtspeech-${QT_PV} )
+       sql? ( >=dev-qt/qtsql-${QT_PV} )
+       svg? ( >=dev-qt/qtsvg-${QT_PV} )
+       testlib? ( >=dev-qt/qttest-${QT_PV} )
+       webchannel? ( >=dev-qt/qtwebchannel-${QT_PV}[qml?] )
+       webengine? ( >=dev-qt/qtwebengine-${QT_PV}[widgets?] )
+       websockets? ( >=dev-qt/qtwebsockets-${QT_PV}[qml?] )
+       widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
+       x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
+       xml? ( >=dev-qt/qtxml-${QT_PV} )
+       xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV}[qml?] )
+"
+DEPEND="${RDEPEND}
+       test? ( x11-misc/xvfb-run )
+"
+
+S=${WORKDIR}/${MY_P}/sources/pyside2
+
+src_configure() {
+       # See COLLECT_MODULE_IF_FOUND macros in CMakeLists.txt
+       local mycmakeargs=(
+               -DBUILD_TESTS=$(usex test)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DAnimation=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DCore=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DExtras=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DInput=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DLogic=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DRender=$(usex !3d)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Charts=$(usex !charts)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Concurrent=$(usex !concurrent)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5DataVisualization=$(usex !datavis)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Designer=$(usex !designer)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Gui=$(usex !gui)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Help=$(usex !help)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Location=$(usex !location)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Multimedia=$(usex !multimedia)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5MultimediaWidgets=$(usex !multimedia yes $(usex !widgets))
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Network=$(usex !network)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Positioning=$(usex !positioning)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5PrintSupport=$(usex !printsupport)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Qml=$(usex !qml)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Quick=$(usex !quick)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5QuickWidgets=$(usex !quick yes $(usex !widgets))
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Script=$(usex !script)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5ScriptTools=$(usex !scripttools)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Scxml=$(usex !scxml)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Sensors=$(usex !sensors)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5TextToSpeech=$(usex !speech)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Sql=$(usex !sql)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Svg=$(usex !svg)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Test=$(usex !testlib)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5UiTools=$(usex !designer)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebChannel=$(usex !webchannel)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngine=$(usex !webengine)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineCore=$(usex !webengine)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets=$(usex !webengine yes $(usex !widgets))
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebSockets=$(usex !websockets)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Widgets=$(usex !widgets)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5X11Extras=$(usex !x11extras)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Xml=$(usex !xml)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Qt5XmlPatterns=$(usex !xmlpatterns)
+       )
+
+       pyside2_configure() {
+               local mycmakeargs=(
+                       "${mycmakeargs[@]}"
+                       -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+                       -DPYTHON_EXECUTABLE="${PYTHON}"
+                       -DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
+                       -DSHIBOKEN_PYTHON_SHARED_LIBRARY_SUFFIX="-${EPYTHON}"
+               )
+               cmake-utils_src_configure
+       }
+       python_foreach_impl pyside2_configure
+}
+
+src_compile() {
+       python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+       local -x PYTHONDONTWRITEBYTECODE
+       python_foreach_impl virtx cmake-utils_src_test
+}
+
+src_install() {
+       pyside2_install() {
+               cmake-utils_src_install
+               python_optimize
+
+               # Uniquify the shiboken2 pkgconfig dependency in the PySide2 pkgconfig
+               # file for the current Python target. See also:
+               #     https://github.com/leycec/raiagent/issues/73
+               sed -i -e 's~^Requires: shiboken2$~&-'${EPYTHON}'~' \
+                       "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}.pc || die
+
+               # Uniquify the PySide2 pkgconfig file for the current Python target,
+               # preserving an unversioned "pyside2.pc" file arbitrarily associated
+               # with the last Python target. (See the previously linked issue.)
+               cp "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+       }
+       python_foreach_impl pyside2_install
+
+       # CMakeLists.txt installs a "PySide2Targets-gentoo.cmake" file forcing
+       # downstream consumers (e.g., pyside2-tools) to target one
+       # "libpyside2-*.so" library linked to one Python interpreter. See also:
+       #     https://bugreports.qt.io/browse/PYSIDE-1053
+       #     https://github.com/leycec/raiagent/issues/74
+       sed -i -e 's~pyside2-python[[:digit:]]\+\.[[:digit:]]\+~pyside2${PYTHON_CONFIG_SUFFIX}~g' \
+               "${ED}/usr/$(get_libdir)/cmake/PySide2-${PV}/PySide2Targets-gentoo.cmake" || die
+}