Change all instances of [ to [[.
authorChris Gianelloni <wolf31o2@gentoo.org>
Wed, 7 Mar 2007 16:14:26 +0000 (16:14 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Wed, 7 Mar 2007 16:14:26 +0000 (16:14 +0000)
Package-Manager: portage-2.1.2.1

games-emulation/virtualjaguar/ChangeLog
games-emulation/virtualjaguar/files/virtualjaguar
games-emulation/xmess/ChangeLog
games-emulation/xmess/xmess-0.105.ebuild
games-emulation/xmess/xmess-0.106.ebuild
games-emulation/xmess/xmess-0.83.1.ebuild

index ddedffedf9141ab0c01473594049481388e91b3d..a6f1ba250b92071d287b26131133c9ffd5d09b2b 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for games-emulation/virtualjaguar
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/ChangeLog,v 1.9 2007/02/21 23:33:06 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/ChangeLog,v 1.10 2007/03/07 16:14:26 wolf31o2 Exp $
+
+  07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> files/virtualjaguar:
+  Change all instances of [ to [[.
 
   21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
   Transition to Manifest2.
index 9d0243be08181c65e06e4c423cde0bd254b2b900..a64c7316aca5e38e96c211a41f283f171d8fe02e 100644 (file)
@@ -3,28 +3,28 @@
 # Script for launching virtualjaguar 
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/files/virtualjaguar,v 1.4 2004/12/12 06:49:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/files/virtualjaguar,v 1.5 2007/03/07 16:14:26 wolf31o2 Exp $
 
 source /sbin/functions.sh
 
 shopt -s nullglob
 
-if [ ! -d ~/.vj/bios ] ; then
+if [[ ! -d ~/.vj/bios ]] ; then
     mkdir -p ~/.vj/bios
 fi
 
-if [ ! -d ~/.vj/eeproms ] ; then
+if [[ ! -d ~/.vj/eeproms ]] ; then
     mkdir -p ~/.vj/eeproms
 fi
 
-if [ ! -d ~/.vj/ROMs ] ; then
+if [[ ! -d ~/.vj/ROMs ]] ; then
     mkdir -p ~/.vj/ROMs
 fi
 
 cd ~/.vj
 
 # check for bios
-if [ -z "`cd ./bios && ls`" ] ; then
+if [[ -z "`cd ./bios && ls`" ]] ; then
        # if the bios directory is empty, then ... well ...
        echo
        eerror "    Put your BIOS file into ~/.vj/bios/"
index 328e15b09d6e6cdf2c45b3be04a04594c5ba161e..a9d0ad45530feed57b78794bae8b619742690566 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-emulation/xmess
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.57 2007/02/21 23:34:06 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.58 2007/03/07 16:10:15 wolf31o2 Exp $
+
+  07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> xmess-0.83.1.ebuild,
+  xmess-0.105.ebuild, xmess-0.106.ebuild:
+  Change all instances of [ to [[.
 
   21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
   Transition to Manifest2.
index 024df40f6d3e9ae03b7c92b845217939f02a4dd8..902722ffce1e2e9c72e998a2d4d88ebf61434c8a 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.105.ebuild,v 1.2 2006/12/01 22:04:28 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.105.ebuild,v 1.3 2007/03/07 16:10:15 wolf31o2 Exp $
 
 inherit flag-o-matic toolchain-funcs eutils games
 
@@ -160,7 +160,7 @@ src_compile() {
                #disp=1
                ewarn "GGI support is currently (${PV}) broken :("
        fi
-       if  [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+       if  [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
                emake DISPLAY_METHOD=x11 || die "emake failed (x11)"
        fi
 }
@@ -190,7 +190,7 @@ src_install() {
                #disp=1
                ewarn "GGI support is currently (${PV}) broken :("
        fi
-       if [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+       if [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
                make DISPLAY_METHOD=x11 install || die "install failed (x11)"
        fi
        exeinto "${GAMES_LIBDIR}/${PN}"
@@ -211,7 +211,7 @@ src_install() {
        # default to sdl since the client is a bit more featureful
        if use sdl ; then
                dosym "${TARGET}.SDL" "${GAMES_BINDIR}/${TARGET}"
-       elif [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+       elif [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
                dosym "${TARGET}.x11" "${GAMES_BINDIR}/${TARGET}"
        elif use svga ; then
                dosym ${TARGET}.svgalib "${GAMES_BINDIR}/${TARGET}"
index 130aeb3e0663930bebb595666d736d300b4772cf..5cd814aa732ec4e491d20188493e5db11e68ab14 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.5 2006/12/01 22:04:28 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.6 2007/03/07 16:10:15 wolf31o2 Exp $
 
 inherit flag-o-matic toolchain-funcs eutils games
 
@@ -161,7 +161,7 @@ src_compile() {
                #disp=1
                ewarn "GGI support is currently (${PV}) broken :("
        fi
-       if  [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+       if  [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
                emake DISPLAY_METHOD=x11 || die "emake failed (x11)"
        fi
 }
@@ -191,7 +191,7 @@ src_install() {
                #disp=1
                ewarn "GGI support is currently (${PV}) broken :("
        fi
-       if [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+       if [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
                make DISPLAY_METHOD=x11 install || die "install failed (x11)"
        fi
        exeinto "${GAMES_LIBDIR}/${PN}"
@@ -212,7 +212,7 @@ src_install() {
        # default to sdl since the client is a bit more featureful
        if use sdl ; then
                dosym "${TARGET}.SDL" "${GAMES_BINDIR}/${TARGET}"
-       elif [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+       elif [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
                dosym "${TARGET}.x11" "${GAMES_BINDIR}/${TARGET}"
        elif use svga ; then
                dosym ${TARGET}.svgalib "${GAMES_BINDIR}/${TARGET}"
index ce5f15efe293995f03b15f04646faa643a4e6065..57824f5bd98b4fe3cd217c08e94c48110b8ce2e7 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.83.1.ebuild,v 1.8 2006/12/01 22:04:28 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.83.1.ebuild,v 1.9 2007/03/07 16:10:15 wolf31o2 Exp $
 
 inherit flag-o-matic toolchain-funcs eutils games
 
@@ -146,7 +146,7 @@ src_unpack() {
 
        case ${ARCH} in
                x86|ia64)       append-flags -Wno-unused -fomit-frame-pointer -fstrict-aliasing -fstrength-reduce -ffast-math
-                       [ $(gcc-major-version) -eq 3 ] \
+                       [[ $(gcc-major-version) -eq 3 ]] \
                                && append-flags -falign-functions=2 -falign-jumps=2 -falign-loops=2 \
                                || append-flags -malign-functions=2 -malign-jumps=2 -malign-loops=2
                        ;;
@@ -187,7 +187,7 @@ src_compile() {
                emake DISPLAY_METHOD=xgl || die "emake failed (xgl)"
                disp=1
        fi
-       if  [ ${disp} -eq 0 ] || use X || use dga || use xv ; then
+       if  [[ ${disp} -eq 0 ]] || use X || use dga || use xv ; then
                emake DISPLAY_METHOD=x11 || die "emake failed (x11)"
        fi
 }
@@ -223,7 +223,7 @@ src_install() {
                make DISPLAY_METHOD=xgl install || die "install failed (xgl)"
                disp=1
        fi
-       if [ ${disp} -eq 0 ] || use X || use dga || use xv ; then
+       if [[ ${disp} -eq 0 ]] || use X || use dga || use xv ; then
                make DISPLAY_METHOD=x11 install || die "install failed (x11)"
        fi
 
@@ -235,7 +235,7 @@ src_install() {
 
        if use opengl ; then
                dosym "${TARGET}.xgl" "${GAMES_BINDIR}/${TARGET}"
-       elif [ ${disp} -eq 0 ] || use X || use dga || use xv ; then
+       elif [[ ${disp} -eq 0 ]] || use X || use dga || use xv ; then
                dosym "${TARGET}.x11" "${GAMES_BINDIR}/${TARGET}"
        elif use sdl ; then
                dosym "${TARGET}.SDL" "${GAMES_BINDIR}/${TARGET}"