New upstream version. Removed old version.
authorOlivier Fisette <ribosome@gentoo.org>
Tue, 12 Dec 2006 20:14:51 +0000 (20:14 +0000)
committerOlivier Fisette <ribosome@gentoo.org>
Tue, 12 Dec 2006 20:14:51 +0000 (20:14 +0000)
Package-Manager: portage-2.1.1-r2

sci-biology/rebase/ChangeLog
sci-biology/rebase/files/digest-rebase-612 [new file with mode: 0644]
sci-biology/rebase/rebase-612.ebuild [new file with mode: 0644]

index 187a173e15d9e1bab0c022a5831e3a8d2576559e..a4f274599604e7af94507c45456e7f9aa07ada48 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sci-biology/rebase
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.80 2006/12/10 19:00:00 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.81 2006/12/12 20:14:51 ribosome Exp $
+
+*rebase-612 (12 Dec 2006)
+
+  12 Dec 2006; Olivier Fisette <ribosome@gentoo.org> -rebase-611.ebuild,
+  +rebase-612.ebuild:
+  New upstream version. Removed old version.
 
   10 Dec 2006; Olivier Fisette <ribosome@gentoo.org> -rebase-601-r1.ebuild,
   -rebase-603.ebuild:
diff --git a/sci-biology/rebase/files/digest-rebase-612 b/sci-biology/rebase/files/digest-rebase-612
new file mode 100644 (file)
index 0000000..b8b486a
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 3f22ae7b80bd88329d803ad8c9b949f5 rebase-612.tar.bz2 183945
+RMD160 bcfedf676553245836e111f4fbb38859439a8ee2 rebase-612.tar.bz2 183945
+SHA256 b075226311e6a367adf27f26bab05b21ff1cf459c6972d292a5ccd07bc0769fd rebase-612.tar.bz2 183945
diff --git a/sci-biology/rebase/rebase-612.ebuild b/sci-biology/rebase/rebase-612.ebuild
new file mode 100644 (file)
index 0000000..4e051dd
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-612.ebuild,v 1.1 2006/12/12 20:14:51 ribosome Exp $
+
+DESCRIPTION="A restriction enzyme database"
+LICENSE="public-domain"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="emboss? ( >=sci-biology/emboss-3.0.0-r1 )"
+
+src_compile() {
+       if use emboss; then
+               echo; einfo "Indexing Rebase for usage with EMBOSS."
+               mkdir REBASE
+               EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${PV} \
+                       -protofile proto.${PV} || die "Indexing Rebase failed."
+               echo
+       fi
+}
+
+src_install() {
+       if ! use minimal; then
+               insinto /usr/share/${PN}
+               doins withrefm.${PV} proto.${PV} || die \
+                       "Failed to install raw database."
+       fi
+       newdoc REBASE.DOC README || die "Failed to install documentation."
+       if use emboss; then
+               insinto /usr/share/EMBOSS/data/REBASE
+               doins REBASE/embossre.{enz,ref,sup} || die \
+                       "Failed to install EMBOSS data files."
+               insinto /usr/share/EMBOSS/data
+               doins embossre.equ || die "Failed to install enzyme prototypes file."
+       fi
+}