dev-python/setuptools-git: Version bump to 1.2
authorManuel Rüger <mrueg@gentoo.org>
Mon, 12 Jun 2017 12:36:39 +0000 (14:36 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Mon, 12 Jun 2017 12:36:39 +0000 (14:36 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-python/setuptools-git/Manifest
dev-python/setuptools-git/setuptools-git-1.2.ebuild [new file with mode: 0644]

index 5f6934e41e971d915e1587cee34c4d1c13e4a98f..009f99e96478ea6fc4b03c82a8166432949fd97b 100644 (file)
@@ -1 +1,2 @@
 DIST setuptools-git-1.1.tar.gz 9450 SHA256 047d7595546635edebef226bc566579d422ccc48a8a91c7d32d8bd174f68f831 SHA512 39e19c107f6398aaa1b78961c3b0d9d7b57b181d8ce0d93780460867fb7535ce45d266b93af43f45aa7afb89299199df22b0fdea61e9090932aeb4bd69c5f1f0 WHIRLPOOL 76a1ff0944c233655c6966fb8e0787d89b8ceb40a09fedb729d67d15905dd82dead4ed88a682db1b4a9ff664f354963b110339f4d96706e19451058dbe870483
+DIST setuptools-git-1.2.tar.gz 10546 SHA256 ff64136da01aabba76ae88b050e7197918d8b2139ccbf6144e14d472b9c40445 SHA512 c070911618b6b92c862fb0bd40f1daeaf79e2ba10389fa1e69e4c50cfdd39c8e57a612082cbc7d932f8cea12a769e13451e35e1c8fe34f170d4817fd0d44f156 WHIRLPOOL 7015b734c7d5acf3623ddb04351ff268608eb1ac3da051e80fec94cff920c2cb43240055dbb9a71118d9b2da91c97e43025e0fbe3b1bf36507e83d90dc891aec
diff --git a/dev-python/setuptools-git/setuptools-git-1.2.ebuild b/dev-python/setuptools-git/setuptools-git-1.2.ebuild
new file mode 100644 (file)
index 0000000..b751cd7
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Setuptools revision control system plugin for Git"
+HOMEPAGE="https://github.com/wichert/setuptools-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+                dev-vcs/git"
+RDEPEND="${DEPEND}"
+
+python_test() {
+       git config --global user.name "test user" || die
+       git config --global user.email "test@email.com" || die
+       esetup.py test
+       retr=$?
+}