dev-python/pytest-asyncio: Use distutils_enable_tests
authorMichał Górny <mgorny@gentoo.org>
Mon, 20 Apr 2020 13:31:35 +0000 (15:31 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 20 Apr 2020 15:48:54 +0000 (17:48 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild

index f7b4cfba907bf8ffedad72e8123948cadc1243df..b5141f97fa04603dea283d2a1a6b00dc88c3ac3a 100644 (file)
@@ -16,11 +16,7 @@ SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> $
 LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="amd64 ~ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
-RDEPEND="
-       dev-python/pytest[${PYTHON_USEDEP}]"
 DEPEND="
        test? (
                ${RDEPEND}
@@ -32,6 +28,8 @@ PATCHES=(
        "${FILESDIR}"/pytest-asyncio-0.10.0-py38.patch
 )
 
+distutils_enable_tests pytest
+
 python_test() {
        distutils_install_for_testing
        pytest -vv || die "Tests fail with ${EPYTHON}"