app-admin/yadm: Security bump to 2.4.0
authorSam James (sam_c) <sam@cmpct.info>
Wed, 25 Mar 2020 20:22:09 +0000 (20:22 +0000)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 28 Mar 2020 00:32:23 +0000 (17:32 -0700)
Fixed in 1.11.1 but bumped to latest while
there given it's now maintainer-needed.

Bug: https://bugs.gentoo.org/625394
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Closes: https://github.com/gentoo/gentoo/pull/15114
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
app-admin/yadm/Manifest
app-admin/yadm/yadm-2.4.0.ebuild [new file with mode: 0644]

index 3ebad2ae5108f1af19f1b314938980f7c1c542de..77a3614ccc961788e4d43b90f2fc9f7e43438639 100644 (file)
@@ -1 +1,2 @@
 DIST yadm-1.12.0.tar.gz 47340 BLAKE2B ef710f56c96244c082bfcc887cae4aee00aaaadec5e7466500dde263c5e4f43df046e11742fd275e989bd9704b39a123f17248cd70d64f6ca552b28db6c44814 SHA512 402a67770154ce3ae7ab947ff4d4e26ca5040d343110fb749195ca5c3f4ee435aba1d8cdf02d4ecf4a81d3f331c1b891bed4fb3fcfcc893867e0fce45b9c8cd8
+DIST yadm-2.4.0.tar.gz 96877 BLAKE2B 462a5816e106c4502007ff34ab338904e14a9851ebcfc7ff79a32a8b11fbbe3e0b7e6538ed6b489ab67e2205c84b2250749e3091c77fa663886dc9792078a576 SHA512 43e16a9502f9dd9f6c6dba3bb5403bb048244a406d44cb42a96a43e62bf7342efd5f302304dbedede61423546787fc929f378d68da9031207e70239ec4e265ce
diff --git a/app-admin/yadm/yadm-2.4.0.ebuild b/app-admin/yadm/yadm-2.4.0.ebuild
new file mode 100644 (file)
index 0000000..b6f903a
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="A dotfile manager for the config files in your home folder"
+HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
+SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       app-crypt/gnupg
+       dev-vcs/git
+"
+
+DEPEND="
+       test? ( dev-tcltk/expect dev-python/pytest ${RDEPEND} )
+"
+
+src_compile() {
+       emake "${PN}.md"
+}
+
+src_test() {
+       # test_encryption: needs write access to /tmp
+       # test_alt, test_compat_jinja, test_unit_template_j2: needs envtpl
+       # test_syntax: needs yamllint (not packaged)
+       # test_compat_alt: known broken, tests deprecated features
+       # test_compat_jinja: needs envtpl
+       rm test/test_encryption.py || die
+       rm test/test_alt.py || die
+       rm test/test_compat_jinja.py || die
+       rm test/test_unit_template_j2.py || die
+       rm test/test_syntax.py || die
+       rm test/test_compat_alt.py || die
+
+       pytest || die "Testsuite failed under ${EPYTHON}"
+}
+
+src_install() {
+       einstalldocs
+
+       dobin "${PN}"
+       doman "${PN}.1"
+
+       newbashcomp completion/yadm.bash_completion yadm
+
+       insinto /usr/share/zsh/site-functions
+       newins completion/yadm.zsh_completion _${PN}
+}