dev-haskell/uri-bytestring: new package, a depend of dev-haskell/persistent-2.6
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 08:39:21 +0000 (08:39 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 10:21:56 +0000 (10:21 +0000)
Haskell URI parsing as ByteStrings

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/uri-bytestring/Manifest [new file with mode: 0644]
dev-haskell/uri-bytestring/metadata.xml [new file with mode: 0644]
dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild [new file with mode: 0644]

diff --git a/dev-haskell/uri-bytestring/Manifest b/dev-haskell/uri-bytestring/Manifest
new file mode 100644 (file)
index 0000000..c7a7276
--- /dev/null
@@ -0,0 +1 @@
+DIST uri-bytestring-0.2.2.1.tar.gz 20755 SHA256 9185e8f05d5c5154348c0d57d0df2b92ba6d09153fbdebded995b2f54e71c67e SHA512 d540722657b80039de25a6893067ea8fa50228420725ea22b95a6b7fb3e99803e41b18006b307973fd38fe5ba58d611d3115d1b677e3a36c38168b92289fee97 WHIRLPOOL 6067dd4e279839e95cb7a972133590612ef64cfeee100b6b339fba7e75779c06d4e8c6edf099189f3014abbfb1d6bf522a2bbd6fbec61477fcca7e372f74c822
diff --git a/dev-haskell/uri-bytestring/metadata.xml b/dev-haskell/uri-bytestring/metadata.xml
new file mode 100644 (file)
index 0000000..e4b66ee
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               uri-bytestring aims to be an RFC3986 compliant URI parser that uses efficient ByteStrings for parsing and representing the URI data.
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild b/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild
new file mode 100644 (file)
index 0000000..1667904
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -lib-werror
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell URI parsing as ByteStrings"
+HOMEPAGE="https://github.com/Soostone/uri-bytestring"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+       >=dev-haskell/blaze-builder-0.3.0.0:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+       >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.16.0
+       test? ( >=dev-haskell/generics-sop-0.2
+               dev-haskell/hunit
+               dev-haskell/lens-simple
+               dev-haskell/quickcheck
+               dev-haskell/quickcheck-instances
+               dev-haskell/semigroups
+               dev-haskell/tasty
+               dev-haskell/tasty-hunit
+               dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+       haskell-cabal_src_configure \
+               --flag=-lib-werror
+}