media-libs/vigra: Fix build with sphinx-2
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 26 Nov 2019 22:23:53 +0000 (23:23 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 27 Nov 2019 00:12:47 +0000 (01:12 +0100)
See also: https://github.com/ukoethe/vigra/issues/462

Closes: https://bugs.gentoo.org/678308
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch [new file with mode: 0644]
media-libs/vigra/vigra-1.11.1-r2.ebuild
media-libs/vigra/vigra-9999.ebuild

diff --git a/media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch b/media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch
new file mode 100644 (file)
index 0000000..fc26576
--- /dev/null
@@ -0,0 +1,27 @@
+Description: Replace sphinx.ext.pngmath by sphinx.ext.imgmath to build with sphinx 1.8
+Bug-Debian: https://bugs.debian.org/923467
+Author: Andreas Tille <tille@debian.org>
+Last-Update: Fri, 08 Mar 2019 18:38:02 +0100
+
+--- a/vigranumpy/docsrc/conf.py.cmake2.in
++++ b/vigranumpy/docsrc/conf.py.cmake2.in
+@@ -59,7 +59,7 @@ os.environ['PATH'] = os.pathsep.join([vi
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.pngmath']
++extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.imgmath']
+ # Add any paths that contain templates here, relative to this directory.
+ templates_path = ['_templates']
+--- a/vigranumpy/docsrc/conf.py.in
++++ b/vigranumpy/docsrc/conf.py.in
+@@ -58,7 +58,7 @@ os.environ['PATH'] = os.pathsep.join([vi
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.pngmath']
++extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.imgmath']
+ # Add any paths that contain templates here, relative to this directory.
+ templates_path = ['_templates']
index 8f4b2b23a1c5d7e581ab0e7d53f6446db27e13fa..757fe839d1986e4ffc829493d68b90542ea1e974 100644 (file)
@@ -69,6 +69,7 @@ PATCHES=(
        "${FILESDIR}/${P}-boost-python.patch"
        # TODO: upstream
        "${FILESDIR}/${P}-lib_suffix.patch"
+       "${FILESDIR}/${P}-sphinx.ext.pngmath.patch" # thanks to Debian; bug 678308
 )
 
 pkg_setup() {
index cad2a8191a7bb75155b27297158aabc711d639e5..6d9d2266b163b3cf185eef834806ae1a912054e0 100644 (file)
@@ -64,7 +64,11 @@ RDEPEND="${PYTHON_DEPS}
 # Severely broken, also disabled in Fedora, bugs #390447, #653442
 RESTRICT="test"
 
-PATCHES=( "${FILESDIR}/${PN}-1.11.1-lib_suffix.patch" )
+PATCHES=(
+       # TODO: upstream
+       "${FILESDIR}/${PN}-1.11.1-lib_suffix.patch"
+       "${FILESDIR}/${PN}-1.11.1-sphinx.ext.pngmath.patch" # thanks to Debian; bug 678308
+)
 
 pkg_setup() {
        if use python || use doc; then