gnome-base/gnome-flashback: bump to 3.34.2
authorMart Raudsepp <leio@gentoo.org>
Sun, 15 Mar 2020 17:34:20 +0000 (19:34 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 15 Mar 2020 17:37:44 +0000 (19:37 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-base/gnome-flashback/Manifest
gnome-base/gnome-flashback/gnome-flashback-3.34.2.ebuild [new file with mode: 0644]

index 82fd65d68767a3124b4c14551e4ae5babadd3130..e294f545c59b0254fee9024a03d4360fb45ed0e3 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-flashback-3.32.0.tar.xz 708624 BLAKE2B 5075daa59b48d9c101a4649ebd89822f4fd4539c30899b152c54d4bb98d48e2174c2c8756f350a76e7576d2430c8609a5c3df7a39f9da80467eb98b9d8b65910 SHA512 ffc89eadf98e269a9d2781d2bac2d551410f3965ab2bf0a60cb904cd1edbaa264d21be1c577381bda1a55f44b919e62ad2735241dc824a901ded6b057d0f2ea0
+DIST gnome-flashback-3.34.2.tar.xz 727812 BLAKE2B dd5fd4ff9f612d464f750343c17f0216366dfc6b9c7d892724e3b78ebf96b492a6192e32edb6c5f7c92c997a1d3325fea2b7e06874a3f03f1e5ea0965c63eba8 SHA512 9c2cfdcd0f896b56c6aff529c372b697fdd52db2660ba658aaef5ff7110a71b756ec708eebd260718ddd1c77df858bd00100070a1a32e282808bac519abb867d
diff --git a/gnome-base/gnome-flashback/gnome-flashback-3.34.2.ebuild b/gnome-base/gnome-flashback/gnome-flashback-3.34.2.ebuild
new file mode 100644 (file)
index 0000000..88af27a
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME Flashback session"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-flashback/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="systemd"
+KEYWORDS="~amd64"
+
+RDEPEND="
+       >=x11-libs/gdk-pixbuf-2.32.2:2
+       >=x11-libs/gtk+-3.22.0:3[X]
+       >=gnome-base/gnome-desktop-3.12.0:3=
+       >=media-libs/libcanberra-0.13[gtk3]
+       >=dev-libs/glib-2.44.0:2
+       >=gnome-base/gsettings-desktop-schemas-3.31.0
+       >=sys-auth/polkit-0.97
+       >=app-i18n/ibus-1.5.2
+       >=sys-power/upower-0.99.0:=
+       >=x11-libs/libXrandr-1.5.0
+       x11-libs/libxcb
+       x11-libs/libX11
+       net-wireless/gnome-bluetooth
+       x11-libs/libXext
+       >=x11-libs/libXi-1.6.0
+       x11-libs/pango
+       x11-libs/libxkbfile
+       x11-misc/xkeyboard-config
+       x11-libs/libXfixes
+       media-sound/pulseaudio[glib]
+"
+DEPEND="${RDEPEND}
+       dev-util/gdbus-codegen
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.8
+       x11-base/xorg-proto
+       virtual/pkgconfig
+" # autoconf-archive for eautoreconf
+RDEPEND="${RDEPEND}
+       x11-wm/metacity
+       gnome-base/gnome-panel
+       gnome-base/gnome-settings-daemon
+"
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-static \
+               $(use_enable systemd systemd-session)
+}