app-portage/pram: Initial version of PR merging tool
authorMichał Górny <mgorny@gentoo.org>
Mon, 18 Mar 2019 19:13:20 +0000 (20:13 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 18 Mar 2019 19:19:15 +0000 (20:19 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/pram/Manifest [new file with mode: 0644]
app-portage/pram/metadata.xml [new file with mode: 0644]
app-portage/pram/pram-1.ebuild [new file with mode: 0644]

diff --git a/app-portage/pram/Manifest b/app-portage/pram/Manifest
new file mode 100644 (file)
index 0000000..9f9ba80
--- /dev/null
@@ -0,0 +1 @@
+DIST pram-1.tar.gz 3759 BLAKE2B da8670ceb689893bde486f6b7332dae8f793b945c71034354853195c4639c2a515533f56fd5ea67b91aba550219cde0a50d7c4c7e60bfeda1877904ecb4e2872 SHA512 fb0d2a2b177973d710d2e68eda82101d64e573e9d90e6aeb2a7bf2be86bcba01b4047c857d6d29d40a5768490a8f999aa001e7e5e45022cf2d1c08bed8ee8d44
diff --git a/app-portage/pram/metadata.xml b/app-portage/pram/metadata.xml
new file mode 100644 (file)
index 0000000..af57dcc
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>mgorny@gentoo.org</email>
+               <name>Michał Górny</name>
+       </maintainer>
+       <upstream>
+               <maintainer status="active">
+                       <email>mgorny@gentoo.org</email>
+                       <name>Michał Górny</name>
+               </maintainer>
+               <bugs-to>https://github.com/mgorny/pram/issues/</bugs-to>
+               <remote-id type="github">mgorny/pram</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/app-portage/pram/pram-1.ebuild b/app-portage/pram/pram-1.ebuild
new file mode 100644 (file)
index 0000000..718e513
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tool to ease merging Pull Requests and git patches"
+HOMEPAGE="https://github.com/mgorny/pram"
+SRC_URI="https://github.com/mgorny/pram/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git
+       net-misc/wget[ssl]
+       virtual/editor
+       !dev-perl/Gentoo-App-Pram"
+
+src_install() {
+       dobin pram
+       einstalldocs
+}