x11-libs/cairo: Drop USE=xlib-xcb flag from unstable versions.
authorMatt Turner <mattst88@gentoo.org>
Sun, 26 Feb 2017 00:10:50 +0000 (16:10 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sun, 26 Feb 2017 00:14:53 +0000 (16:14 -0800)
Has caused no end of problems. See bugs 441878, 476306, 477444, 477530,
508232.

x11-libs/cairo/cairo-1.14.8.ebuild
x11-libs/cairo/cairo-9999.ebuild

index acdfced63dc7ca06f47b0f4c5aac49b929afaae7..023f08cfa85fdbcf312af542d6c53f618ec98901 100644 (file)
@@ -19,7 +19,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
 HOMEPAGE="http://cairographics.org/"
 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
 SLOT="0"
-IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg valgrind xcb xlib-xcb"
+IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg valgrind xcb"
 # gtk-doc regeneration doesn't seem to work with out-of-source builds
 #[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
 
@@ -63,7 +63,6 @@ DEPEND="${RDEPEND}
 
 REQUIRED_USE="
        gles2? ( !opengl )
-       xlib-xcb? ( xcb )
 "
 
 MULTILIB_WRAPPED_HEADERS=(
@@ -133,7 +132,6 @@ multilib_src_configure() {
                $(use_enable valgrind) \
                $(use_enable xcb) \
                $(use_enable xcb xcb-shm) \
-               $(use_enable xlib-xcb) \
                --enable-ft \
                --enable-pdf \
                --enable-png \
@@ -142,6 +140,7 @@ multilib_src_configure() {
                --disable-gallium \
                --disable-qt \
                --disable-vg \
+               --disable-xlib-xcb \
                ${myopts}
 }
 
@@ -149,15 +148,3 @@ multilib_src_install_all() {
        prune_libtool_files --all
        einstalldocs
 }
-
-pkg_postinst() {
-       if use !xlib-xcb; then
-               if has_version net-misc/nxserver-freenx \
-                               || has_version net-misc/x2goserver; then
-                       ewarn "cairo-1.12 is known to cause GTK+ errors with NX servers."
-                       ewarn "Enable USE=\"xlib-xcb\" if you notice incorrect behavior in GTK+"
-                       ewarn "applications that are running inside NX sessions. For details, see"
-                       ewarn "https://bugs.gentoo.org/441878 or https://bugs.freedesktop.org/59173"
-               fi
-       fi
-}
index 7ec16d48f5ac4a65a92e3e1cabb6ff44753019e6..39c733894be6f5dfb8d2fdb40f04f7c3e54b558e 100644 (file)
@@ -19,7 +19,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
 HOMEPAGE="http://cairographics.org/"
 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
 SLOT="0"
-IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg utils valgrind xcb xlib-xcb"
+IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg utils valgrind xcb"
 # gtk-doc regeneration doesn't seem to work with out-of-source builds
 #[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
 
@@ -64,7 +64,6 @@ DEPEND="${RDEPEND}
 
 REQUIRED_USE="
        gles2? ( !opengl )
-       xlib-xcb? ( xcb )
 "
 
 MULTILIB_WRAPPED_HEADERS=(
@@ -136,7 +135,6 @@ multilib_src_configure() {
                $(use_enable valgrind) \
                $(use_enable xcb) \
                $(use_enable xcb xcb-shm) \
-               $(use_enable xlib-xcb) \
                --enable-ft \
                --enable-pdf \
                --enable-png \
@@ -145,6 +143,7 @@ multilib_src_configure() {
                --disable-gallium \
                --disable-qt \
                --disable-vg \
+               --disable-xlib-xcb \
                ${myopts}
 }
 
@@ -152,15 +151,3 @@ multilib_src_install_all() {
        prune_libtool_files --all
        einstalldocs
 }
-
-pkg_postinst() {
-       if use !xlib-xcb; then
-               if has_version net-misc/nxserver-freenx \
-                               || has_version net-misc/x2goserver; then
-                       ewarn "cairo-1.12 is known to cause GTK+ errors with NX servers."
-                       ewarn "Enable USE=\"xlib-xcb\" if you notice incorrect behavior in GTK+"
-                       ewarn "applications that are running inside NX sessions. For details, see"
-                       ewarn "https://bugs.gentoo.org/441878 or https://bugs.freedesktop.org/59173"
-               fi
-       fi
-}