net-libs/sofia-sip: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sun, 9 Feb 2020 18:49:27 +0000 (19:49 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 9 Feb 2020 18:49:27 +0000 (19:49 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
net-libs/sofia-sip/sofia-sip-1.12.11.ebuild

index 0cef361a73d16e7d13ca20713b7e319664579fa0..243bb87cbb2138e79405fa2b74b56a0b1f2fe564 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 DESCRIPTION="RFC3261 compliant SIP User-Agent library"
 HOMEPAGE="http://sofia-sip.sourceforge.net/"
@@ -10,28 +10,29 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
 LICENSE="LGPL-2.1+ BSD public-domain" # See COPYRIGHT
 SLOT="0"
 KEYWORDS="~alpha amd64 ~arm arm64 ia64 ppc ~ppc64 sparc x86 ~x86-linux"
-IUSE="libressl ssl static-libs"
-
-RDEPEND="dev-libs/glib:2
-       ssl? (
-               !libressl? ( dev-libs/openssl )
-               libressl? ( dev-libs/libressl )
-       )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-
+IUSE="libressl ssl"
 # tests are broken, see bugs 304607 and 330261
 RESTRICT="test"
 
-DOCS=( AUTHORS ChangeLog README README.developers RELEASE TODO )
+RDEPEND="
+       dev-libs/glib:2
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
 
 src_configure() {
        econf \
-               $(use_enable static-libs static) \
+               --disable-static \
                $(use_with ssl openssl)
 }
 
 src_install() {
        default
-       rm -f "${ED}"usr/lib*/lib${PN}*.la
+       dodoc RELEASE
+
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }