media-sound/qsynth: 0.5.5 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 27 Mar 2019 20:48:08 +0000 (21:48 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 30 Mar 2019 09:58:21 +0000 (10:58 +0100)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-sound/qsynth/Manifest
media-sound/qsynth/qsynth-0.5.5.ebuild [new file with mode: 0644]

index 877cecc7504ae7981047d5289092325c79470262..9d28c1872322daa752f30ec67628689a039cb23a 100644 (file)
@@ -1,2 +1,3 @@
 DIST qsynth-0.5.3.tar.gz 269252 BLAKE2B c496063ba33bc78a65d63151871e841f9d3938fe03049655da3c124fd495c592f9c726c479062c3fb2d1561e4dee3284d12b04e04a51ba06e20d297b6e84ac0f SHA512 15632274e5822f5e1a49bd332c5d8b7e59a54800ad32510f425f06b4557e474d5479bd531b45fc43af20535017a656fbd9469d318940931912a56ea1856dc117
 DIST qsynth-0.5.4.tar.gz 268106 BLAKE2B e7e17c1427cbb6105fc6fbaa511325fcfbed0d06e28374e3b9fdce14a633e6554267339bb1ffe2bf1f16fbebf38095ae02eca86d74412add3a1e16d191cd1e45 SHA512 711b18efea3b4050c567f2c549ab4f44525f53de42c6cfea379260e62966215e6d59432bed946733c7e772d691edb739a882de753cf3f46b932833de7b120b7d
+DIST qsynth-0.5.5.tar.gz 269061 BLAKE2B e17bb0ced40764c5bef9ae7c793f7ba1ebfe4edd761f434ad129f338d30384c639f27d697ecfdaa93d7fff52c38bed0a3b95cf51fbdad25e13c14abe795d49dd SHA512 4e90b38d428c6b49a78b648ac9604e683f32623898205abe3a98c4136c5b29ab27c101cf63207dbbfdcba105913de2dcb5cc7669a6433def71d071f39cf68429
diff --git a/media-sound/qsynth/qsynth-0.5.5.ebuild b/media-sound/qsynth/qsynth-0.5.5.ebuild
new file mode 100644 (file)
index 0000000..8c607d5
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic qmake-utils
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="alsa debug jack pulseaudio"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+"
+DEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtwidgets:5
+       media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.4.0-qt5-tagging.patch" )
+
+src_configure() {
+       append-cxxflags -std=c++11
+       sed -e "/@gzip.*mandir)\/man1/d" -i Makefile.in || die
+       econf \
+               $(use_enable debug)
+
+       eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_install () {
+       emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+       einstalldocs
+
+       # The desktop file is invalid, and we also change the command
+       # depending on useflags
+       rm "${ED}/usr/share/applications/qsynth.desktop" || die
+
+       local cmd
+       if use jack; then
+               cmd="qsynth"
+       elif use pulseaudio; then
+               cmd="qsynth -a pulseaudio"
+       elif use alsa; then
+               cmd="qsynth -a alsa"
+       else
+               cmd="qsynth -a oss"
+       fi
+
+       make_desktop_entry "${cmd}" Qsynth qsynth
+}