sci-mathematics/why3-for-spark: version bump to 2019
authorTupone Alfredo <tupone@gentoo.org>
Fri, 11 Oct 2019 07:28:10 +0000 (09:28 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Fri, 11 Oct 2019 07:28:10 +0000 (09:28 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
sci-mathematics/why3-for-spark/Manifest
sci-mathematics/why3-for-spark/files/why3-for-spark-2019-gentoo.patch [new file with mode: 0644]
sci-mathematics/why3-for-spark/why3-for-spark-2019.ebuild [new file with mode: 0644]

index 8f9c5c3c62dc21b03778b32aa3bd214f66f025cb..e2f1ef56af67dd9325bd315d63393eb645bbabb1 100644 (file)
@@ -1 +1,2 @@
+DIST why3-2019-20190517-197BB-src.tar.gz 9439414 BLAKE2B 68072064e8ee9152528c90afc948047a1f4d58b960ac05b276761fdca5ba1204100c75f33db7bb0ea1a8a646b734e62892ed41bd875b954354f52b8f9d498d4a SHA512 9169a4ff9ee994a19f9f04b689d1b9c679f5340bcd631d7d49b4c55064f505bd5a6ca8149077e5d24d36f5365f0cab58587094e86f352a9105fc46f10c0746ba
 DIST why3-for-spark-gpl-2018-src.tar.gz 7682767 BLAKE2B 0b0272ca4d5519ca402990b234d0847378bcd2a0949fea78ea10e355233a16aebe79b938cdf8e4daadabb909171cab83b9d6ccacf9f2dc1c0b57bb6da6fd1fe0 SHA512 fc798acf343484fd8e70f470a318753c9a0e9967ff579f20ec185bf3c2a75e7a4a556388fc86a378610ce4a467f3e722c6f610da34d4c33bc3d6b10551731f07
diff --git a/sci-mathematics/why3-for-spark/files/why3-for-spark-2019-gentoo.patch b/sci-mathematics/why3-for-spark/files/why3-for-spark-2019-gentoo.patch
new file mode 100644 (file)
index 0000000..f83a625
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/src/gnat/gnat_config.ml  2017-10-18 09:07:03.118919785 +0200
++++ b/src/gnat/gnat_config.ml  2017-10-18 09:07:45.198216939 +0200
+@@ -12,10 +12,7 @@
+   | Limit_Check of Gnat_expl.check
+   | Limit_Line of Gnat_loc.loc
+-let spark_prefix =
+-  (Filename.dirname
+-          (Filename.dirname (Filename.dirname
+-          (Filename.dirname Sys.executable_name))))
++let spark_prefix = "/usr"
+ let rec file_concat l =
+   match l with
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2019.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2019.ebuild
new file mode 100644 (file)
index 0000000..a0caa7b
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MYP=why3-${PV}-20190517-197BB-src
+
+DESCRIPTION="Platform for deductive program verification"
+HOMEPAGE="http://why3.lri.fr/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5cdf915d31e87a8f1c967d54
+       -> ${MYP}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="coq doc emacs gtk html hypothesis-selection +ocamlopt profiling zarith zip"
+RESTRICT=strip
+
+DEPEND=">=dev-lang/ocaml-4.02.3[ocamlopt?]
+       dev-ml/menhir
+       coq? ( sci-mathematics/coq )
+       doc? ( dev-tex/rubber )
+       gtk? ( dev-ml/lablgtk[sourceview] )
+       emacs? ( virtual/emacs )
+       html? ( dev-tex/hevea )
+       hypothesis-selection? ( dev-ml/ocamlgraph )
+       zarith? ( dev-ml/zarith )
+       zip? ( >=dev-ml/camlzip-1.07 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MYP}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+REQUIRED_USE="html? ( doc )"
+
+src_configure() {
+       econf \
+               --disable-pvs-libs \
+               --disable-isabelle-libs \
+               --enable-verbose-make \
+               $(use_enable coq coq-libs) \
+               $(use_enable doc) \
+               $(use_enable emacs emacs-compilation) \
+               $(use_enable gtk ide) \
+               $(use_enable html html-doc) \
+               $(use_enable hypothesis-selection) \
+               $(use_enable ocamlopt native-code) \
+               $(use_enable profiling) \
+               $(use_enable zarith) \
+               $(use_enable zip)
+}
+
+src_compile() {
+       emake -j1
+       if use ocamlopt; then
+               emake byte
+       fi
+       use doc && emake doc
+}
+
+src_install() {
+       emake DESTDIR="${D}" -j1 install
+       emake DESTDIR="${D}" -j1 install-lib
+       emake DESTDIR="${D}" install_spark2014_dev
+       dosym ../why3server /usr/$(get_libdir)/why3/commands/why3server
+       einstalldocs
+       docompress -x /usr/share/doc/${PF}/examples
+       dodoc -r examples
+       if use doc; then
+               dodoc doc/manual.pdf
+               use html && dodoc -r doc/html
+       fi
+}