sci-mathematics/rw: new revision sans the "rw" executable.
authorMichael Orlitzky <mjo@gentoo.org>
Fri, 28 Feb 2020 12:51:34 +0000 (07:51 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Fri, 28 Feb 2020 12:53:33 +0000 (07:53 -0500)
The main use case for rw is as a library, specifically one used by
SageMath. The "rw" executable was nice to have, but it pulls in
dev-libs/igraph, and igraph upstream has gone crazy and started
copy/pasting libraries into its "src" directory. Since igraph
will never be upgraded like that, it's staying unmaintained and
won't be stabilized, thereby blocking the stabilization of rw.

This commit drops the "rw" executable entirely, so that we can get rid
of the igraph dependency and stabilize a version of rw.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
sci-mathematics/rw/metadata.xml
sci-mathematics/rw/rw-0.8-r2.ebuild [moved from sci-mathematics/rw/rw-0.8-r1.ebuild with 69% similarity]

index 76588843b8fb7033b3bfaad95503ed2d20b2c807..4a95d1f4b12d3b2a3ec1fbab013a512fc24530ee 100644 (file)
     additions on masked integers" by Michael D. Adams and David S. Wise.
   </longdescription>
 
-  <use>
-    <flag name="executable">Build the 'rw' program.</flag>
-  </use>
-
   <upstream>
     <remote-id type="sourceforge">rankwidth</remote-id>
   </upstream>
similarity index 69%
rename from sci-mathematics/rw/rw-0.8-r1.ebuild
rename to sci-mathematics/rw/rw-0.8-r2.ebuild
index 4ccfc56281e1b0ed6894ee00103c5771ae8b5bbc..cd1ab5d589b163c7d431eed226fadea98358c258 100644 (file)
@@ -12,13 +12,10 @@ SRC_URI="https://downloads.sourceforge.net/project/rankwidth/${P}.tar.gz"
 LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="+executable"
-
-DEPEND="executable? ( >=dev-libs/igraph-0.6 )"
+IUSE=""
 
 # We have a file collision (librw.so) with xpaint, bug 560210.
-RDEPEND="${DEPEND}
-       !media-gfx/xpaint"
+RDEPEND="!media-gfx/xpaint"
 
 src_prepare() {
        # The upstream tarball for v0.8 contains SYMLINKS to ar-lib,
@@ -30,13 +27,7 @@ src_prepare() {
 }
 
 src_configure() {
-       econf $(use_enable executable)
-}
-
-src_install() {
-       default
-       # The examples graphs are meant to be fed uncompressed into the 'rw'
-       # program. The rest of the docs are small so just leave everything
-       # uncompressed.
-       docompress -x /usr/share/doc/${PF}
+       # The executable depends on igraph, which has gone off the rails
+       # upstream and has copy/pasted ~10 libraries into its src/ directory.
+       econf --disable-executable
 }