www-client/qutebrowser: Force libyaml use flag on for pyyaml dependency
authorJay Kamat <jaygkamat@gmail.com>
Wed, 30 Jan 2019 07:14:06 +0000 (23:14 -0800)
committerJustin Bronder <jsbronder@gentoo.org>
Thu, 31 Jan 2019 02:43:09 +0000 (21:43 -0500)
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Jay Kamat <jaygkamat@gmail.com>
Signed-off-by: Justin Bronder <jsbronder@gentoo.org>
www-client/qutebrowser/qutebrowser-1.5.2-r1.ebuild [moved from www-client/qutebrowser/qutebrowser-1.5.2.ebuild with 93% similarity]
www-client/qutebrowser/qutebrowser-9999.ebuild

similarity index 93%
rename from www-client/qutebrowser/qutebrowser-1.5.2.ebuild
rename to www-client/qutebrowser/qutebrowser-1.5.2-r1.ebuild
index 2ac3df7f628eeae3785c81f07ec877bd6af4e8c4..9870584a71be3858149d22d9c06d2334d4a95702 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -31,7 +31,7 @@ RDEPEND="${COMMON_DEPEND}
        >=dev-python/pygments-2.1.3[${PYTHON_USEDEP}]
        >=dev-python/pypeg2-2.15.2[${PYTHON_USEDEP}]
        >=dev-python/PyQt5-5.7.1[${PYTHON_USEDEP},declarative,multimedia,gui,network,opengl,printsupport,sql,webengine,widgets]
-       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP},libyaml]
 "
 
 # Tests restricted as the deplist (misc/requirements/requirements-tests.txt)
@@ -58,10 +58,6 @@ python_install_all() {
        distutils-r1_python_install_all
 }
 
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
 pkg_postinst() {
        optfeature "PDF display support" www-plugins/pdfjs
        xdg_desktop_database_update
index 2ac3df7f628eeae3785c81f07ec877bd6af4e8c4..9870584a71be3858149d22d9c06d2334d4a95702 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -31,7 +31,7 @@ RDEPEND="${COMMON_DEPEND}
        >=dev-python/pygments-2.1.3[${PYTHON_USEDEP}]
        >=dev-python/pypeg2-2.15.2[${PYTHON_USEDEP}]
        >=dev-python/PyQt5-5.7.1[${PYTHON_USEDEP},declarative,multimedia,gui,network,opengl,printsupport,sql,webengine,widgets]
-       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP},libyaml]
 "
 
 # Tests restricted as the deplist (misc/requirements/requirements-tests.txt)
@@ -58,10 +58,6 @@ python_install_all() {
        distutils-r1_python_install_all
 }
 
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
 pkg_postinst() {
        optfeature "PDF display support" www-plugins/pdfjs
        xdg_desktop_database_update