Version bump.
authorAlin Năstac <mrness@gentoo.org>
Mon, 26 Mar 2007 09:11:39 +0000 (09:11 +0000)
committerAlin Năstac <mrness@gentoo.org>
Mon, 26 Mar 2007 09:11:39 +0000 (09:11 +0000)
Package-Manager: portage-2.1.2.2

app-mobilephone/bitpim/ChangeLog
app-mobilephone/bitpim/bitpim-0.9.13.ebuild [moved from app-mobilephone/bitpim/bitpim-0.9.08.ebuild with 94% similarity]
app-mobilephone/bitpim/files/bitpim-0.9.08-gentoo.patch [deleted file]
app-mobilephone/bitpim/files/bitpim-0.9.13-gentoo.patch [new file with mode: 0644]
app-mobilephone/bitpim/files/digest-bitpim-0.9.08 [deleted file]
app-mobilephone/bitpim/files/digest-bitpim-0.9.13 [new file with mode: 0644]
app-mobilephone/galicesms/ChangeLog
app-mobilephone/galicesms/files/digest-galicesms-1.3.1 [deleted file]
app-mobilephone/galicesms/files/digest-galicesms-1.51 [new file with mode: 0644]
app-mobilephone/galicesms/galicesms-1.51.ebuild [moved from app-mobilephone/galicesms/galicesms-1.3.1.ebuild with 83% similarity]

index 7399fe0df04682854a4bedb51ed4f1c263967b80..cf16ec8e823184c87c3266c2542be4a14a5c38f6 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for app-mobilephone/bitpim
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/ChangeLog,v 1.18 2007/01/16 17:55:25 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/ChangeLog,v 1.19 2007/03/26 09:07:15 mrness Exp $
+
+*bitpim-0.9.13 (26 Mar 2007)
+
+  26 Mar 2007; Alin Năstac <mrness@gentoo.org>
+  -files/bitpim-0.9.08-gentoo.patch, +files/bitpim-0.9.13-gentoo.patch,
+  -bitpim-0.9.08.ebuild, +bitpim-0.9.13.ebuild:
+  Version bump.
 
 *bitpim-0.9.10 (16 Jan 2007)
 
similarity index 94%
rename from app-mobilephone/bitpim/bitpim-0.9.08.ebuild
rename to app-mobilephone/bitpim/bitpim-0.9.13.ebuild
index 27ca76d8b635f15e87601ad13b1635101770563c..86902276f555199dbc065829bfd48cd1fbcd9639 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/bitpim-0.9.08.ebuild,v 1.1 2006/12/02 14:18:48 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/bitpim-0.9.13.ebuild,v 1.1 2007/03/26 09:07:15 mrness Exp $
 
 inherit distutils multilib
 
@@ -137,11 +137,11 @@ src_install() {
 
        # Creating scripts
        echo '#!/bin/sh' > "${T}/bitpim"
-       echo "exec python ${RLOC}/bp.py bitpim \"\$@\"" >> "${T}/bitpim"
+       echo "exec python ${RLOC}/bp.py \"\$@\"" >> "${T}/bitpim"
        dobin "${T}/bitpim"
        if use crypt; then
                echo '#!/bin/sh' > "${T}/bitfling"
-               echo "exec python ${RLOC}/bp.py bitfling \"\$@\"" >> "${T}/bitfling"
+               echo "exec python ${RLOC}/bp.py \"\$@\" bitfling" >> "${T}/bitfling"
                dobin "${T}/bitfling"
        fi
 
diff --git a/app-mobilephone/bitpim/files/bitpim-0.9.08-gentoo.patch b/app-mobilephone/bitpim/files/bitpim-0.9.08-gentoo.patch
deleted file mode 100644 (file)
index db2b5ef..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-diff -Nru bitpim-0.9.08.orig/src/bp.py bitpim-0.9.08/src/bp.py
---- bitpim-0.9.08.orig/src/bp.py       2006-09-04 05:24:41.000000000 +0300
-+++ bitpim-0.9.08/src/bp.py    2006-12-02 16:13:01.552641919 +0200
-@@ -49,7 +49,7 @@
-     if sys.platform=="darwin" and len(sys.argv)>1 and sys.argv[1].startswith("-psn_"):
-       # get rid of the process serial number on mac
-       sys.argv=sys.argv[:1]+sys.argv[2:]
--    _options, _args=getopt.getopt(sys.argv[1:], 'c:d:')
-+    _options, _args=getopt.gnu_getopt(sys.argv[1:], 'c:d:')
-     _kwargs={}
-     # check for debug flag
-     _debug=__debug__ or bool(_args and 'debug' in _args)
-diff -Nru bitpim-0.9.08.orig/src/common.py bitpim-0.9.08/src/common.py
---- bitpim-0.9.08.orig/src/common.py   2006-08-27 01:44:28.000000000 +0300
-+++ bitpim-0.9.08/src/common.py        2006-12-02 16:13:01.552641919 +0200
-@@ -854,4 +854,4 @@
-         # windows running from exe, return as is
-         return os.path.abspath(os.path.dirname(sys.executable))
-     # running from src, up one
--    return os.path.split(os.path.abspath(os.path.dirname(sys.argv[0])))[0]
-+    return os.path.abspath(os.path.dirname(sys.argv[0]))
-diff -Nru bitpim-0.9.08.orig/src/conversions.py bitpim-0.9.08/src/conversions.py
---- bitpim-0.9.08.orig/src/conversions.py      2006-05-28 06:10:52.000000000 +0300
-+++ bitpim-0.9.08/src/conversions.py   2006-12-02 16:13:01.552641919 +0200
-@@ -20,11 +20,11 @@
- class ConversionFailed(Exception): pass
--helperdir=os.path.join(common.get_main_dir(), "helpers")
-+helperdir="/usr/bin"
- osext={'win32': '.exe',
-        'darwin': '.mbin',
--       'linux2': '.lbin'} \
-+       'linux2': ''} \
-        [sys.platform]
- # This shortname crap is needed because Windows programs (including ffmpeg)
-@@ -125,14 +125,14 @@
-     p=sys.path[0]
-     if os.path.isfile(p):
-         p=os.path.dirname(p)
--    helpersdirectory=os.path.abspath(os.path.join(p, 'helpers'))
-+    helpersdirectory="/usr/bin"
-     print "Helper Directory: "+helpersdirectory
-     if sys.platform=='win32':
-         osext=".exe"
-     if sys.platform=='darwin':
-         osext=".mbin"
-     if sys.platform=='linux2':
--        osext=".lbin"
-+        osext=""
-         
-     pngtopnmbin=gethelperbinary('pngtopnm')
-     ppmquantbin=gethelperbinary('ppmquant')
-diff -Nru bitpim-0.9.08.orig/src/native/av/bmp2avi/Makefile bitpim-0.9.08/src/native/av/bmp2avi/Makefile
---- bitpim-0.9.08.orig/src/native/av/bmp2avi/Makefile  2006-05-05 10:10:08.000000000 +0300
-+++ bitpim-0.9.08/src/native/av/bmp2avi/Makefile       2006-12-02 16:13:01.552641919 +0200
-@@ -13,6 +13,6 @@
- SRC=avi_file.cxx bmp_file.cxx b2a.cxx
--bmp2avi.lbin bmp2avi.mbin bmp2avi.exe: $(SRC)
-+bmp2avi bmp2avi.mbin bmp2avi.exe: $(SRC)
-       $(CXX) $(EXTRADEFINES) -O2 -o $@ $(SRC)
-diff -Nru bitpim-0.9.08.orig/src/native/usb/build.sh bitpim-0.9.08/src/native/usb/build.sh
---- bitpim-0.9.08.orig/src/native/usb/build.sh 2006-03-04 06:57:24.000000000 +0200
-+++ bitpim-0.9.08/src/native/usb/build.sh      2006-12-02 16:13:01.556642169 +0200
-@@ -4,4 +4,4 @@
- swig -python -I/usr/include libusb.i
- gcc -fPIC -Wall -fno-strict-aliasing -O2 -g  -shared  -I $INCLUDEDIR -o _libusb.so libusb_wrap.c -lusb 
--strip _libusb.so
-+#strip _libusb.so
diff --git a/app-mobilephone/bitpim/files/bitpim-0.9.13-gentoo.patch b/app-mobilephone/bitpim/files/bitpim-0.9.13-gentoo.patch
new file mode 100644 (file)
index 0000000..4b58057
--- /dev/null
@@ -0,0 +1,90 @@
+diff -Nru bitpim-0.9.13.orig/src/common.py bitpim-0.9.13/src/common.py
+--- bitpim-0.9.13.orig/src/common.py   2007-03-08 05:20:16.000000000 +0200
++++ bitpim-0.9.13/src/common.py        2007-03-26 11:52:31.000000000 +0300
+@@ -859,7 +859,7 @@
+         # windows running from exe, return as is
+         return os.path.abspath(os.path.dirname(sys.executable))
+     # running from src, up one
+-    return os.path.split(os.path.abspath(os.path.dirname(sys.argv[0])))[0]
++    return os.path.abspath(os.path.dirname(sys.argv[0]))
+ if sys.platform=='win32':
+     # From Tim Golden's Win32 How Do I ...?
+diff -Nru bitpim-0.9.13.orig/src/conversions.py bitpim-0.9.13/src/conversions.py
+--- bitpim-0.9.13.orig/src/conversions.py      2006-05-28 06:10:52.000000000 +0300
++++ bitpim-0.9.13/src/conversions.py   2007-03-26 11:52:31.000000000 +0300
+@@ -20,11 +20,11 @@
+ class ConversionFailed(Exception): pass
+-helperdir=os.path.join(common.get_main_dir(), "helpers")
++helperdir="/usr/bin"
+ osext={'win32': '.exe',
+        'darwin': '.mbin',
+-       'linux2': '.lbin'} \
++       'linux2': ''} \
+        [sys.platform]
+ # This shortname crap is needed because Windows programs (including ffmpeg)
+@@ -125,14 +125,14 @@
+     p=sys.path[0]
+     if os.path.isfile(p):
+         p=os.path.dirname(p)
+-    helpersdirectory=os.path.abspath(os.path.join(p, 'helpers'))
++    helpersdirectory="/usr/bin"
+     print "Helper Directory: "+helpersdirectory
+     if sys.platform=='win32':
+         osext=".exe"
+     if sys.platform=='darwin':
+         osext=".mbin"
+     if sys.platform=='linux2':
+-        osext=".lbin"
++        osext=""
+         
+     pngtopnmbin=gethelperbinary('pngtopnm')
+     ppmquantbin=gethelperbinary('ppmquant')
+diff -Nru bitpim-0.9.13.orig/src/importexport.py bitpim-0.9.13/src/importexport.py
+--- bitpim-0.9.13.orig/src/importexport.py     2007-01-10 00:28:37.000000000 +0200
++++ bitpim-0.9.13/src/importexport.py  2007-03-26 11:52:41.000000000 +0300
+@@ -21,7 +21,7 @@
+ import wx.html
+ # Others
+-from thirdparty import DSV
++import DSV
+ # My modules
+ import common
+diff -Nru bitpim-0.9.13.orig/src/native/av/bmp2avi/Makefile bitpim-0.9.13/src/native/av/bmp2avi/Makefile
+--- bitpim-0.9.13.orig/src/native/av/bmp2avi/Makefile  2006-05-05 10:10:08.000000000 +0300
++++ bitpim-0.9.13/src/native/av/bmp2avi/Makefile       2007-03-26 11:52:31.000000000 +0300
+@@ -13,6 +13,6 @@
+ SRC=avi_file.cxx bmp_file.cxx b2a.cxx
+-bmp2avi.lbin bmp2avi.mbin bmp2avi.exe: $(SRC)
++bmp2avi bmp2avi.mbin bmp2avi.exe: $(SRC)
+       $(CXX) $(EXTRADEFINES) -O2 -o $@ $(SRC)
+diff -Nru bitpim-0.9.13.orig/src/native/usb/build.sh bitpim-0.9.13/src/native/usb/build.sh
+--- bitpim-0.9.13.orig/src/native/usb/build.sh 2006-03-04 06:57:24.000000000 +0200
++++ bitpim-0.9.13/src/native/usb/build.sh      2007-03-26 11:52:31.000000000 +0300
+@@ -4,4 +4,4 @@
+ swig -python -I/usr/include libusb.i
+ gcc -fPIC -Wall -fno-strict-aliasing -O2 -g  -shared  -I $INCLUDEDIR -o _libusb.so libusb_wrap.c -lusb 
+-strip _libusb.so
++#strip _libusb.so
+diff -Nru bitpim-0.9.13.orig/src/phones/com_samsung.py bitpim-0.9.13/src/phones/com_samsung.py
+--- bitpim-0.9.13.orig/src/phones/com_samsung.py       2007-01-10 00:28:37.000000000 +0200
++++ bitpim-0.9.13/src/phones/com_samsung.py    2007-03-26 11:52:47.000000000 +0300
+@@ -16,7 +16,7 @@
+ import time
+ # site-packages
+-from thirdparty import DSV
++import DSV
+ # BitPim modules
+ import bpcalendar
diff --git a/app-mobilephone/bitpim/files/digest-bitpim-0.9.08 b/app-mobilephone/bitpim/files/digest-bitpim-0.9.08
deleted file mode 100644 (file)
index a7b8154..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 b7c9c614419a4a571418f0c4a9ac7717 bitpim-0.9.08.tar.bz2 3958117
-RMD160 82d508db4551b8b865f85f2b0573939dce58057c bitpim-0.9.08.tar.bz2 3958117
-SHA256 f958a54372535447209bf015c017331e16a0aa2fc9bf7554211c47ed1bd8ab66 bitpim-0.9.08.tar.bz2 3958117
diff --git a/app-mobilephone/bitpim/files/digest-bitpim-0.9.13 b/app-mobilephone/bitpim/files/digest-bitpim-0.9.13
new file mode 100644 (file)
index 0000000..16c8090
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 7dc382767a1c7aa1048c60d98bb7475e bitpim-0.9.13.tar.bz2 4212639
+RMD160 e2a3159ed8b53ac44a07b69e2533ec90b2bb3529 bitpim-0.9.13.tar.bz2 4212639
+SHA256 f43b88049d9f57a6ea51d72c2009f7b079b555aaa7b5e6b5b8b1681af6acca62 bitpim-0.9.13.tar.bz2 4212639
index b8e222472e3d4be96853fc6d5dbc72b2230570b3..477137213c1684ad026c09fad6ca2e4accf446e9 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-mobilephone/galicesms
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/galicesms/ChangeLog,v 1.4 2007/01/16 18:00:17 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/galicesms/ChangeLog,v 1.5 2007/03/26 09:11:39 mrness Exp $
+
+*galicesms-1.51 (26 Mar 2007)
+
+  26 Mar 2007; Alin Năstac <mrness@gentoo.org> -galicesms-1.3.1.ebuild,
+  +galicesms-1.51.ebuild:
+  Version bump.
 
 *galicesms-1.4.0 (16 Jan 2007)
 
diff --git a/app-mobilephone/galicesms/files/digest-galicesms-1.3.1 b/app-mobilephone/galicesms/files/digest-galicesms-1.3.1
deleted file mode 100644 (file)
index 0f3237d..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 c62c4820635422e37a1f9426070cd5ea galicesms-1.3.1.tar.gz 6288
-RMD160 24391e064b6253e4919c2a6e6102bccbc9567264 galicesms-1.3.1.tar.gz 6288
-SHA256 6094b9c6356c1c576ac53292f180d338d5f2e280781d72f240b442ce7880b14e galicesms-1.3.1.tar.gz 6288
diff --git a/app-mobilephone/galicesms/files/digest-galicesms-1.51 b/app-mobilephone/galicesms/files/digest-galicesms-1.51
new file mode 100644 (file)
index 0000000..4d57fee
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 74b63e479d18e14c3e0044c0531f1bcf galicesms-1.51.tar.gz 7543
+RMD160 4924bf4149c3a3067b590981d44a578fd9a1bb0a galicesms-1.51.tar.gz 7543
+SHA256 3c0ed871a7314eb64efcbf5fbbbd94e9dc91961aa45c780e129c86c3f17c37ac galicesms-1.51.tar.gz 7543
similarity index 83%
rename from app-mobilephone/galicesms/galicesms-1.3.1.ebuild
rename to app-mobilephone/galicesms/galicesms-1.51.ebuild
index 2b50d034874fb4938ccd5730b4b260429c388adc..6bab1fd3f383af95b7ef1e2347e326c84dffd7ba 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/galicesms/galicesms-1.3.1.ebuild,v 1.1 2006/07/15 15:01:58 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/galicesms/galicesms-1.51.ebuild,v 1.1 2007/03/26 09:11:39 mrness Exp $
 
 DESCRIPTION="GTK2 GUI interface for sending SMS messages via Rosso Alice (Italian ADSL service)"
 HOMEPAGE="http://www.marzocca.net/linux/galicesms.html"