dev-ada/xmlada: die when compile fails
authorTupone Alfredo <tupone@gentoo.org>
Mon, 19 Jun 2017 19:30:19 +0000 (21:30 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Mon, 19 Jun 2017 19:30:19 +0000 (21:30 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.1

dev-ada/xmlada/xmlada-2017.ebuild

index d2d897d203e39cc0465f9f13474cf59dc20d396f..7b42b3188719b61f75027c7869535f789e5264a8 100644 (file)
@@ -32,13 +32,13 @@ src_compile () {
        if use shared; then
                gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=relocatable \
                        -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
-                       -cargs ${ADAFLAGS}
+                       -cargs ${ADAFLAGS} || die "gprbuild failed"
        fi
        for kind in static static-pic; do
                if use ${kind}; then
                        gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=${kind} \
                                -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
-                               -cargs ${ADAFLAGS}
+                               -cargs ${ADAFLAGS} || die "gprbuild failed"
                fi
        done
 }