dev-python/pyacoustid: 1.1.7 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 7 Dec 2019 17:37:23 +0000 (18:37 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 7 Dec 2019 22:51:39 +0000 (23:51 +0100)
Non-maintainer commit.

Closes: https://bugs.gentoo.org/696668
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/pyacoustid/Manifest
dev-python/pyacoustid/pyacoustid-1.1.7.ebuild [new file with mode: 0644]

index b2cab13fe92eb81b04d2dee52fb54b940bdf63cd..270a271aa091381d9afab3a37e458c55792f9f83 100644 (file)
@@ -1,2 +1,3 @@
 DIST pyacoustid-1.0.0.tar.gz 10476 BLAKE2B 363bf1bee4c124fc57126febf50c34a395ded074df8d3b9661b015b6b653f473ef79837f2078b7b21375d3b3624f75b1070d3c28ab3fa4d619e1ae088129898c SHA512 4eabf32e7d958bf7330e852184f5ddf3105007179ca2c45b75c1a5b0f0898649e703aa333cffccac85eb7b18b54255f2e5d588897adfb9f0ef2596e9c0b2fe5a
 DIST pyacoustid-1.1.5.tar.gz 11846 BLAKE2B 920894d914f5eac15bd62fab7a018937691e8eb7774fe65821bd6a8088e81dba19d178866bfd01b991750c6298714a1b51f948da987207a6adad1e0c1689afa4 SHA512 5b71446b9adbc73335b5962081e880365580b8e0aac746e8137e8819ba91d73ec41814eba13fd1b04c5bad5f2b5a3aaad57db118981ab4eac9dea12f709afe91
+DIST pyacoustid-1.1.7.tar.gz 14990 BLAKE2B 866fa4a03032f15daa2b8dd06119eb6edc777dec4bc673fe2564363f85906bbe451b2ca16e6911e143e7172c728f1a700f5fc426f9a4de9786c1429e475379cc SHA512 2bd301ce51df8a352c71493dac5b5c15cdd0af0a9a0bf0c8640857a9d99c5f0c9d59c5c2bf8c2aec61689481dacc42948f847e0c11ac7d581a7338e6d1088162
diff --git a/dev-python/pyacoustid/pyacoustid-1.1.7.ebuild b/dev-python/pyacoustid/pyacoustid-1.1.7.ebuild
new file mode 100644 (file)
index 0000000..f5c4e4e
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Chromaprint and the AcoustID web service"
+HOMEPAGE="https://pypi.org/project/pyacoustid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       dev-python/audioread[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       media-libs/chromaprint
+"
+
+src_install() {
+       distutils-r1_src_install
+
+       if use examples ; then
+               docinto examples
+               dodoc aidmatch.py fpcalc.py
+               docompress -x /usr/share/doc/${PF}/examples/
+       fi
+}