net-mail/Freemail: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Wed, 16 Oct 2019 08:07:37 +0000 (10:07 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 16 Oct 2019 08:14:05 +0000 (10:14 +0200)
Closes: https://bugs.gentoo.org/628914
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-mail/Freemail/Freemail-9999-r1.ebuild [deleted file]
net-mail/Freemail/files/build.patch [deleted file]
net-mail/Freemail/metadata.xml [deleted file]
profiles/package.mask

diff --git a/net-mail/Freemail/Freemail-9999-r1.ebuild b/net-mail/Freemail/Freemail-9999-r1.ebuild
deleted file mode 100644 (file)
index 5220b68..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-EGIT_REPO_URI="https://github.com/freenet/plugin-Freemail-official.git"
-EGIT_PROJECT="Freemail/official"
-EANT_BUILD_TARGET="dist"
-inherit eutils git-2 java-pkg-2 java-ant-2
-
-DESCRIPTION="Anonymous IMAP/SMTP e-mail server over Freenet"
-HOMEPAGE="https://github.com/freenet/plugin-Freemail"
-SRC_URI=""
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-CDEPEND="dev-java/bcprov:1.38
-       net-p2p/freenet"
-DEPEND="${CDEPEND}
-       >=virtual/jdk-1.5"
-RDEPEND="${CDEPEND}
-       >=virtual/jre-1.5"
-
-EANT_GENTOO_CLASSPATH="bcprov freenet"
-
-src_prepare() {
-       epatch "${FILESDIR}"/build.patch
-       java-ant_rewrite-classpath
-}
-
-src_install() {
-       java-pkg_dojar dist/"${PN}.jar"
-       dodir /var/freenet/plugins
-       fperms freenet:freenet /var/freenet/plugins
-       dodoc README || die "installation of documentation failed"
-}
-
-pkg_postinst () {
-       #force chmod for previously existing plugins dir owned by root
-       [[ $(stat --format="%U" /var/freenet/plugins) == "freenet" ]] || chown \
-               freenet:freenet /var/freenet/plugins
-       elog "To load Freemail, go to the plugin page of freenet and enter at"
-       elog "Plugin-URL: /usr/share/Freemail/lib/Freemail.jar"
-       elog " This should load the Freemail plugin."
-       elog "Set your email client to IMAP port 3143 and SMTP port 3025 on localhost."
-       elog "To bind freemail to different ports, or to a different freenet node, edit"
-       elog "/var/freenet/globalconfig."
-}
diff --git a/net-mail/Freemail/files/build.patch b/net-mail/Freemail/files/build.patch
deleted file mode 100644 (file)
index 3fef282..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
---- build.xml  2009-06-26 16:46:58.829728329 +0200
-+++ build.xml.new      2009-06-26 16:48:44.654930593 +0200
-@@ -5,64 +5,7 @@
-       <property name="build" location="build"/>
-       <property name="lib" location="lib"/>
-       <property name="dist" location="dist"/>
--      <property name="deps" location="deps"/>
--      
--      <property name="bcdist" value="lcrypto-jdk14-138"/>
--      <property name="freenetjarurl.url" value="http://downloads.freenetproject.org/alpha/freenet-testing-latest.jar.url"/>
--      <property name="freenetjarurl.localpath" value="${deps}/freenet-testing-latest.jar.url"/>
--      <property name="freenetjar" value="freenet-main.jar"/>
--
--      <target name="freenetjar-check">
--              <available file="${deps}/${freenetjar}" property="freenetjar.present" />
--      </target>
--
--      <!-- Fetching the Freenet jar here is far from optimal:
--           Ideally we'd compile against a the freenet jar or class files
--           which the user almost certainly has on their computer already.
--           Unfortunately about the only sensible way of doing this would
--           be with Maven2, and both Freenet and Freemail import code from
--           other projects which would make things difficult and/or ugly.
--      -->
--      <target name="freenetjar-fetch" depends="freenetjar-check" unless="freenetjar.present">
--              <echo>
--                      Attempting to fetch Freenet main jar - ant cannot do this reliably, so if it fails, delete ${deps}/${freenetjar} and ${freenetjarurl.localpath} and run ant again.
--              </echo>
--              <mkdir dir="${deps}" />
--              <!-- loadresource directly from an HTTP URL is causing problems -->
--              <get src="${freenetjarurl.url}"
--                      dest="${freenetjarurl.localpath}" />
--              <loadfile property="freenetjar.url"
--                      srcFile="${freenetjarurl.localpath}" />
--              <get src="${freenetjar.url}" 
--                      dest="${deps}/${freenetjar}" 
--                      verbose="true" />
--      </target>
--      
--      <target name="bouncycastle-check">
--              <available file="${deps}/${bcdist}" property="bouncycastle-dist.present" />
--              <available file="${build}/org/bouncycastle" property="bouncycastle-bin.present" />
--      </target>
--
--      <target name="bouncycastle-fetch" depends="bouncycastle-check" unless="bouncycastle-dist.present">
--              <mkdir dir="${deps}" />
--              <get src="http://www.bouncycastle.org/download/${bcdist}.zip" 
--              dest="${deps}/${bcdist}.zip" 
--              verbose="true"
--              usetimestamp="true" />
--
--              <unzip src="${deps}/${bcdist}.zip" dest="${deps}" />
--      </target>
--
--      <target name="bouncycastle-compile" depends="bouncycastle-fetch" unless="bouncycastle-bin.present">
--              <mkdir dir="build" />
--              <javac srcdir="${deps}/${bcdist}/src" destdir="${build}" debug="on" optimize="on" source="1.4" nowarn="true">
--                      <exclude name="**/test/*" />
--                      <exclude name="org/bouncycastle/util/IPTest.java" />
--                      <exclude name="org/bouncycastle/util/AllTests.java" />
--              </javac>
--      </target>
--
--      <target name="compile" depends="bouncycastle-compile, freenetjar-fetch">
-+      <target name="compile">
-               <mkdir dir="${build}"/>
-               <tstamp/>
diff --git a/net-mail/Freemail/metadata.xml b/net-mail/Freemail/metadata.xml
deleted file mode 100644 (file)
index 3800f75..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="person">
-               <email>tommy@gentoo.org</email>
-               <name>Thomas Sachau (Tommy[D])</name>
-       </maintainer>
-</pkgmetadata>
index 81b916b8fdb8c1afdbef178d2c9b854b938b481f..1ce5eecbcb9ab2b07a70ad070d137aa53a20ad8b 100644 (file)
@@ -455,13 +455,6 @@ app-emulation/vmips-cross-bin
 # Removal in 30 days.  Bug #694390.
 dev-go/go-oauth2
 
-# Thomas Sachau <tommy@gentoo.org> (2019-09-14)
-# Freemail has been completly rewritten so the current
-# ebuild does no longer work for it. In addition the source
-# has moved. So masking for removal.
-# Removal in 30 days. Bug #628914
-net-mail/Freemail
-
 # Lars Wendler <polynomial-c@gentoo.org> (2019-09-04)
 # Unofficial build. Superseded by official 2.49.5 release.
 # Masked for removal.