dev-ruby/rails-dom-testing: add ruby27
authorHans de Graaff <graaff@gentoo.org>
Thu, 12 Mar 2020 08:36:08 +0000 (09:36 +0100)
committerHans de Graaff <graaff@gentoo.org>
Thu, 12 Mar 2020 08:43:56 +0000 (09:43 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild b/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild
new file mode 100644 (file)
index 0000000..b920ceb
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
+HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "
+       >=dev-ruby/activesupport-4.2.0:*
+       >=dev-ruby/nokogiri-1.6"
+
+each_ruby_test() {
+       ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}