Version bump, fixed bug #137503 and possible others. Dropped old version.
authorTiziano Müller <dev-zero@gentoo.org>
Sat, 30 Dec 2006 00:03:32 +0000 (00:03 +0000)
committerTiziano Müller <dev-zero@gentoo.org>
Sat, 30 Dec 2006 00:03:32 +0000 (00:03 +0000)
Package-Manager: portage-2.1.2_rc4-r1

dev-python/python-ldap/ChangeLog
dev-python/python-ldap/files/digest-python-ldap-2.0.11
dev-python/python-ldap/files/digest-python-ldap-2.2.1 [new file with mode: 0644]
dev-python/python-ldap/python-ldap-2.2.1.ebuild [new file with mode: 0644]

index 2384f3dd92bcab44abd1633ea585b09763332a64..9a50980a0a883b236e727ca6026606032eb98d72 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/python-ldap
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.43 2006/12/22 19:44:44 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.44 2006/12/30 00:03:32 dev-zero Exp $
+
+*python-ldap-2.2.1 (30 Dec 2006)
+
+  30 Dec 2006; Tiziano Müller <dev-zero@gentoo.org>
+  -python-ldap-2.2.0.ebuild, +python-ldap-2.2.1.ebuild:
+  Version bump, fixed bug #137503 and possible others. Dropped old version.
 
   22 Dec 2006; Markus Rothe <corsair@gentoo.org> python-ldap-2.2.0.ebuild:
   Added ~ppc64; bug #158855
index d619960a12821639480210ba3d3d7e052783f6cf..382f4de748d1f7e857fb4269499e5ad0c59e2365 100644 (file)
@@ -1,2 +1,4 @@
 MD5 5b788a9c88c4ba645a16226a6291f8df html-python-ldap-docs-2.0.3.tar.gz 25857
+RMD160 2dbbdfd1ac420aea441ca31e785efb33aad1c652 html-python-ldap-docs-2.0.3.tar.gz 25857
+SHA256 d39a4ae2f72b18e7f17f3c01d6d204b97c7c91521c918c0dd9155705b843ad66 html-python-ldap-docs-2.0.3.tar.gz 25857
 MD5 1c20cdbe8cfab1c92b39848f7deeb6ec python-ldap-2.0.11.tar.gz 71715
diff --git a/dev-python/python-ldap/files/digest-python-ldap-2.2.1 b/dev-python/python-ldap/files/digest-python-ldap-2.2.1
new file mode 100644 (file)
index 0000000..d7ffedc
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 5b788a9c88c4ba645a16226a6291f8df html-python-ldap-docs-2.0.3.tar.gz 25857
+RMD160 2dbbdfd1ac420aea441ca31e785efb33aad1c652 html-python-ldap-docs-2.0.3.tar.gz 25857
+SHA256 d39a4ae2f72b18e7f17f3c01d6d204b97c7c91521c918c0dd9155705b843ad66 html-python-ldap-docs-2.0.3.tar.gz 25857
+MD5 d674ce378d7612ceffe16e93d83e0404 python-ldap-2.2.1.tar.gz 73122
+RMD160 3eaa28ff399aa42ca527145b0d607dec5d422c20 python-ldap-2.2.1.tar.gz 73122
+SHA256 eb8ce76c6df7a3f5139baad0b1e5c2d7e1cee73eead992a77deea0ffa00979c4 python-ldap-2.2.1.tar.gz 73122
diff --git a/dev-python/python-ldap/python-ldap-2.2.1.ebuild b/dev-python/python-ldap/python-ldap-2.2.1.ebuild
new file mode 100644 (file)
index 0000000..f691735
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.2.1.ebuild,v 1.1 2006/12/30 00:03:32 dev-zero Exp $
+
+inherit distutils
+
+P_DOC="html-python-ldap-docs-2.0.3"
+
+DESCRIPTION="Various LDAP-related Python modules"
+SRC_URI="mirror://sourceforge/python-ldap/${P}.tar.gz
+       doc? ( mirror://sourceforge/python-ldap/${P_DOC}.tar.gz )"
+HOMEPAGE="http://python-ldap.sourceforge.net/"
+SLOT="0"
+LICENSE="PYTHON"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc sasl ssl"
+
+DEPEND=">=net-nds/openldap-2.2
+       sasl? ( dev-libs/cyrus-sasl )"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="ldap"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       # Note: we can't add /usr/lib and /usr/lib/sasl2 to library_dirs due to a bug in py2.4
+       sed -e "s:^library_dirs =.*:library_dirs =:" \
+               -e "s:^include_dirs =.*:include_dirs = ${ROOT}usr/include:" \
+               -e "s:\(extra_compile_args =\).*:\1\nextra_link_args = -Wl,-rpath=${ROOT}usr/lib -Wl,-rpath=${ROOT}usr/lib/sasl2:" \
+               -i setup.cfg || die "error fixing setup.cfg"
+
+       local mylibs="ldap"
+       if use sasl ; then
+               use ssl && mylibs="ldap_r"
+               mylibs="${mylibs} sasl2"
+       fi
+       use ssl && mylibs="${mylibs} ssl crypto"
+
+       # Fixes bug #25693
+       sed -e "s|<sasl.h>|<sasl/sasl.h>|" -i Modules/LDAPObject.c
+
+       sed -e "s:^libs = .*:libs = lber resolv ${mylibs}:" \
+               -e "s:^compile.*:compile = 0:" \
+               -e "s:^optimize.*:optimize = 0:" \
+               -i setup.cfg || die "error setting up libs in setup.cfg"
+}
+
+src_install() {
+       distutils_src_install
+       if use doc ; then
+               dohtml -r "${WORKDIR}/${P_DOC/html-/}"/*
+               insinto /usr/share/doc/${PF}
+               doins -r Demo
+       fi
+}