dev-python/google-apputils: Fix permissions on unpacked files
authorMike Gilbert <floppym@gentoo.org>
Sun, 27 Sep 2015 12:49:12 +0000 (08:49 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sun, 27 Sep 2015 12:49:12 +0000 (08:49 -0400)
Bug: https://bugs.gentoo.org/561266

Package-Manager: portage-2.2.22_p3

dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild [moved from dev-python/google-apputils/google-apputils-0.4.0.ebuild with 91% similarity]
dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild [moved from dev-python/google-apputils/google-apputils-0.4.2.ebuild with 89% similarity]

similarity index 91%
rename from dev-python/google-apputils/google-apputils-0.4.0.ebuild
rename to dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild
index a285ff34bc5261ba9dc9995373b75504c32f3892..4ed6025a284285a8e17aa3b699f488056271eb9a 100644 (file)
@@ -25,6 +25,12 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
                dev-python/mox[${PYTHON_USEDEP}] )"
 # version borders needed are already confluent with versions in the tree
 
+src_unpack() {
+       default
+       find ${P} -type d -exec chmod 0755 {} + || die
+       find ${P} -type f -exec chmod 0644 {} + || die
+}
+
 python_prepare_all() {
        # https://code.google.com/p/google-apputils-python/source/detail?r=12
        # This version bordering is long out of date and wrong since end of March 2012!
similarity index 89%
rename from dev-python/google-apputils/google-apputils-0.4.2.ebuild
rename to dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild
index 055a248b970c87504c0e8584d9073797223afb04..613b4dcc67353e920849b0a5f7b7561c15a65001 100644 (file)
@@ -24,6 +24,12 @@ RDEPEND="
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( ${RDEPEND} dev-python/mox[${PYTHON_USEDEP}] )"
 
+src_unpack() {
+       default
+       find ${P} -type d -exec chmod 0755 {} + || die
+       find ${P} -type f -exec chmod 0644 {} + || die
+}
+
 python_test() {
        # These yield 2 fails which are in fact expected errors run from a shell script!
        # They seemingly have no immediate mechanism to exit 0 in an expected fail style.