dev-python/urllib3: Skip tests requiring 'localhost.' resolvable
authorMichał Górny <mgorny@gentoo.org>
Mon, 9 Mar 2020 17:51:55 +0000 (18:51 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 9 Mar 2020 17:52:42 +0000 (18:52 +0100)
Closes: https://bugs.gentoo.org/711920
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/urllib3/urllib3-1.25.8.ebuild

index 66703bcc3a1fa71f7173163cfa8523c30e548ada..3279a2e0cbe078023203f64eda462860ded47ca3 100644 (file)
@@ -53,6 +53,11 @@ python_prepare_all() {
                -i test/with_dummyserver/test_https.py || die
        sed -e 's:test_https_proxy_.*timeout:_&:' \
                -i test/with_dummyserver/test_proxy_poolmanager.py || die
+       # tests failing if 'localhost.' cannot be resolved
+       sed -e 's:test_dotted_fqdn:_&:' \
+               -i test/with_dummyserver/test_https.py || die
+       sed -e 's:test_request_host_header_ignores_fqdn_dot:_&:' \
+               -i test/with_dummyserver/test_socketlevel.py || die
        # no clue why those fail, might be tornado's fault, might be just
        # very flaky
        sed -e 's:test_client_no_intermediate:_&:' \