app-leechcraft/lc-azoth: bump EAPI, add subslot ops
author0xd34df00d <0xd34df00d@gmail.com>
Sat, 4 Apr 2020 20:48:18 +0000 (16:48 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 9 Apr 2020 12:37:42 +0000 (15:37 +0300)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-leechcraft/lc-azoth/lc-azoth-9999.ebuild

index 0eadc74c2bcd6f6d26f9f6f9eb4961c3f94f8f22..79223f027924f1c1d17b51957e8f78a1e34b2308 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit leechcraft
 
@@ -37,11 +37,11 @@ COMMON_DEPEND="
        )
        sarin? (
                dev-qt/qtconcurrent:5
-               net-libs/tox
+               net-libs/tox:=
        )
        woodpecker? ( dev-libs/kqoauth )
        xmpp? (
-               >=net-libs/qxmpp-0.9.3-r1
+               >=net-libs/qxmpp-1.2.0
                media? ( net-libs/qxmpp[speex] )
        )
        xtazy? ( ~app-leechcraft/lc-xtazy-${PV} )
@@ -98,11 +98,11 @@ src_configure() {
                -DENABLE_AZOTH_XTAZY=$(usex xtazy)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        use doc && dodoc -r "${CMAKE_BUILD_DIR}"/out/html/*
 }