games-action/garden: Build with gcc:5.2
authorTupone Alfredo <tupone@gentoo.org>
Tue, 22 Sep 2015 07:03:38 +0000 (09:03 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Tue, 22 Sep 2015 07:04:46 +0000 (09:04 +0200)
Package-Manager: portage-2.2.20.1

games-action/garden/files/garden-1.0.9-gcc52.patch [new file with mode: 0644]
games-action/garden/garden-1.0.9.ebuild

diff --git a/games-action/garden/files/garden-1.0.9-gcc52.patch b/games-action/garden/files/garden-1.0.9-gcc52.patch
new file mode 100644 (file)
index 0000000..60f9272
--- /dev/null
@@ -0,0 +1,20 @@
+--- src/stuff.c.old    2015-09-22 08:57:21.482794770 +0200
++++ src/stuff.c        2015-09-22 08:58:22.567815095 +0200
+@@ -52,7 +52,7 @@
+ float cos_table[ANGLE_1];
+ float sin_table[ANGLE_1];
+-inline int xpart (int angle, int length);
++extern inline int xpart (int angle, int length);
+ void init_trig (void)
+ {
+@@ -72,7 +72,7 @@
+       return (cos_table[angle & 1023] * length);
+ }
+-inline int ypart (int angle, int length)
++extern inline int ypart (int angle, int length)
+ {
+       return (sin_table[angle & 1023] * length);
+ }
index 62df12c7f80ace35a53db335071f0ab8c4084d8d..63eb620271a3c734ae2e7f9b141d5866ef5f22f1 100644 (file)
@@ -20,7 +20,8 @@ RDEPEND="${DEPEND}"
 src_prepare() {
        epatch \
                "${FILESDIR}"/${P}-dash.patch \
-               "${FILESDIR}"/${P}-resources.patch
+               "${FILESDIR}"/${P}-resources.patch \
+               "${FILESDIR}"/${P}-gcc52.patch
        eautoreconf
 }