www-client/chromium: restore missing ebuild changes
authorMike Gilbert <floppym@gentoo.org>
Sun, 16 Jun 2019 01:08:21 +0000 (21:08 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sun, 16 Jun 2019 01:08:35 +0000 (21:08 -0400)
Package-Manager: Portage-2.3.67_p4, Repoman-2.3.13_p3
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
www-client/chromium/chromium-75.0.3770.80.ebuild

index ebf3d3be40ed675e5378aabd9a708bc9c6ae1a5a..0dde4528fb7373e0a6cd277c468e24a240fe9474 100644 (file)
@@ -136,6 +136,8 @@ are not displayed properly:
 To fix broken icons on the Downloads page, you should install an icon
 theme that covers the appropriate MIME types, and configure this as your
 GTK+ icon theme.
+
+For native file dialogs in KDE, install kde-apps/kdialog.
 "
 
 PATCHES=(
@@ -554,9 +556,6 @@ src_configure() {
        # Disable fatal linker warnings, bug 506268.
        myconf_gn+=" fatal_linker_warnings=false"
 
-       # https://bugs.gentoo.org/588596
-       # append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
-
        # Bug 491582.
        export TMPDIR="${WORKDIR}/temp"
        mkdir -p -m 755 "${TMPDIR}" || die
@@ -596,9 +595,6 @@ src_compile() {
 
        #"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
 
-       # Work around broken deps
-       eninja -C out/Release gen/ui/accessibility/ax_enums.mojom{,-shared}.h
-
        # Build mksnapshot and pax-mark it.
        local x
        for x in mksnapshot v8_context_snapshot_generator; do
@@ -699,20 +695,12 @@ src_install() {
 }
 
 pkg_postrm() {
-       if type gtk-update-icon-cache &>/dev/null; then
-               ebegin "Updating GTK icon cache"
-               gtk-update-icon-cache "${EROOT}/usr/share/icons/hicolor"
-               eend $?
-       fi
+       xdg_icon_cache_update
        xdg_desktop_database_update
 }
 
 pkg_postinst() {
-       if type gtk-update-icon-cache &>/dev/null; then
-               ebegin "Updating GTK icon cache"
-               gtk-update-icon-cache "${EROOT}/usr/share/icons/hicolor"
-               eend $?
-       fi
+       xdg_icon_cache_update
        xdg_desktop_database_update
        readme.gentoo_print_elog
 }