dev-libs/libtasn1: version bump
authorAlon Bar-Lev <alonbl@gentoo.org>
Sat, 5 Sep 2015 06:54:34 +0000 (09:54 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Sat, 5 Sep 2015 06:56:06 +0000 (09:56 +0300)
Package-Manager: portage-2.2.20.1

dev-libs/libtasn1/Manifest
dev-libs/libtasn1/libtasn1-4.6.ebuild [new file with mode: 0644]

index a0cdb84065b3fc568ae08669bb64386eb75e31e9..28214e6b8ac3cf0c0461dc71cb3d09be739e32b5 100644 (file)
@@ -1 +1,2 @@
 DIST libtasn1-4.5.tar.gz 1850279 SHA256 89b3b5dce119273431544ecb305081f3530911001bb12e5d76588907edb71bda SHA512 9319c7109b006f6f1f52c5cc0ff4b076db0037fb977535e04980dc3a9b3195ef20a451f04771d0eff1d1a104557cc14ccd5147f82e4229230d6539046e7f5108 WHIRLPOOL 9a3673f576f0ff44889c00f4c24e3f2d9b27f0be1d53058b292ed56f89b2b4efbd0ac0f9721daa0ed1116b541146e86b8f42d9e8857bdc9d0ba8bacb5415a9dd
+DIST libtasn1-4.6.tar.gz 1852124 SHA256 3462fc25e2d2536878c39a8825f5e36ba2e2611b27ef535e064f4c56258e508b SHA512 865215b21ff13cd3998e1dbc893a0c9897e08611549a22e0aa42e068e8531c4b28226fe16bc27e1018cf3e0d481f86fa70d15a29a68b1aad155c4fa4f84a3d81 WHIRLPOOL fe2801328190b4ee75c379db6ab2fd7480641f2a2d25109bcc225d4e09431c580dad7f89342704ae20832dabebceadf38dc932ccb8d0aa3fab1e91e3b27e4b5a
diff --git a/dev-libs/libtasn1/libtasn1-4.6.ebuild b/dev-libs/libtasn1/libtasn1-4.6.ebuild
new file mode 100644 (file)
index 0000000..00b5a07
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib
+
+DESCRIPTION="ASN.1 library"
+HOMEPAGE="https://www.gnu.org/software/libtasn1/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0/6" # subslot = libtasn1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc static-libs"
+
+DEPEND=">=dev-lang/perl-5.6
+       sys-apps/help2man
+       virtual/yacc"
+RDEPEND="
+       abi_x86_32? (
+               !<=app-emulation/emul-linux-x86-baselibs-20131008-r16
+               !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+       )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+src_configure() {
+       local myeconfargs
+       [[ "${VALGRIND_TESTS}" == "0" ]] && myeconfargs+=( --disable-valgrind-tests )
+       autotools-multilib_src_configure
+}
+
+src_install() {
+       autotools-multilib_src_install
+
+       if use doc ; then
+               dodoc doc/libtasn1.pdf
+               dohtml doc/reference/html/*
+       fi
+}