dev-python/rpyc: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:15:46 +0000 (17:15 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:15:46 +0000 (17:15 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/rpyc/rpyc-3.4.4.ebuild
dev-python/rpyc/rpyc-4.0.2.ebuild

index 0cf647f2ebaa27e9bdea66e255011a9aa719c9a2..e08292707e8c6783db0fdeed881a14d9e328a60d 100644 (file)
@@ -1,17 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python3_{5,6} )
 
 inherit distutils-r1
 
 DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
 HOMEPAGE="https://rpyc.readthedocs.io/en/latest/"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE=""
+
 RDEPEND="dev-python/plumbum"
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
index f3e1ff38ded2878d3425290f1fa712e9ce742669..5132a2d564b424ea340376298664b9a6d7c01ecc 100644 (file)
@@ -1,17 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
 
 inherit distutils-r1
 
 DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
 HOMEPAGE="https://rpyc.readthedocs.io/en/latest/"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
+
 RDEPEND="dev-python/plumbum[${PYTHON_USEDEP}]"
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"