dev-python/pyopenssl: Use distutils_enable_sphinx
authorMichał Górny <mgorny@gentoo.org>
Mon, 25 Nov 2019 12:25:16 +0000 (13:25 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 Nov 2019 12:35:15 +0000 (13:35 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyopenssl/pyopenssl-19.1.0.ebuild

index 751bbcc01bcb0f6839130aacf021d3c63e53b6c4..fde3dc7c660d58878d79b7a07c47378c948d57b2 100644 (file)
@@ -18,23 +18,18 @@ HOMEPAGE="
        https://github.com/pyca/pyopenssl
 "
 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
 
 LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
+IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
        >=dev-python/cryptography-2.8[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
-       doc? (
-               $(python_gen_any_dep '
-                       dev-python/sphinx[${PYTHON_USEDEP}]
-                       dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-               ')
-       )
        test? (
                virtual/python-cffi[${PYTHON_USEDEP}]
                dev-python/flaky[${PYTHON_USEDEP}]
@@ -42,13 +37,8 @@ DEPEND="${RDEPEND}
                >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}]
        )"
 
-S=${WORKDIR}/${MY_P}
-
-python_check_deps() {
-       use doc || return 0
-       has_version "dev-python/sphinx[${PYTHON_USEDEP}]" &&
-               has_version "dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
-}
+distutils_enable_sphinx doc \
+       dev-python/sphinx_rtd_theme
 
 python_prepare_all() {
        # Requires network access
@@ -56,15 +46,6 @@ python_prepare_all() {
        distutils-r1_python_prepare_all
 }
 
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
 python_test() {
        TZ=UTC pytest -vv || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
 }
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       distutils-r1_python_install_all
-}