dev-python/django: bump to 1.11.20/2.0.13/2.1.7
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 12 Feb 2019 13:28:12 +0000 (08:28 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 12 Feb 2019 13:28:39 +0000 (08:28 -0500)
upstream scrambled quite a bit for this release...

Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/django/Manifest
dev-python/django/django-1.11.20.ebuild [new file with mode: 0644]
dev-python/django/django-2.0.13.ebuild [new file with mode: 0644]
dev-python/django/django-2.1.7.ebuild [new file with mode: 0644]

index 32532cf417665d64f5df41dc4f6e02d2a38712bd..d6dce4d20dad549c2226c83e77c594819b601511 100644 (file)
@@ -1,3 +1,6 @@
 DIST Django-1.11.18.tar.gz 7847617 BLAKE2B e5c97a370c47caba2aea53245fdd8d11218c91d8fba230f2e2e9ab8068fbb7ebce6c7a969016d62a08a8226e13664b54202073b7726b7d6091d1f45dccde9ca1 SHA512 35c885e835c5e85257774c65c11bf851e710c745df3366487159f21f90e092236dd8d2cee86e8165945e57fc710989b0ea2747682fa4ce37d5e93d4f664b76c1
+DIST Django-1.11.20.tar.gz 7846576 BLAKE2B 11423edda7f2f08cc894957da65c746c99ce7ce5399ff236972cce627e347cbc4a43c7ff75282318fac2ac8f65fc4db691ac9fe8e04059b0de4f1bfe31278382 SHA512 5a0fff6c9b90a08e98dee6d4d090047adb900a8f6a061f98e685e8998bfe3d97fe7a90aa7d4d2feae67026fb6e4441393d50cb5ab295604ed362a080b987f062
 DIST Django-2.0.10.tar.gz 7992290 BLAKE2B af4ee0841e01911c987128f70c0a3570951fc57cbd75165c8b81a4b6847a29fdff7de4f17f5f80e2f4e6b8e87aee017b256f45380fbea931e257f2a999175d78 SHA512 aee171bc10387b2685930887ed9e86564fba273210cd9d7929b7a97eb913ab537408a779bd06c37be63b3b9ecd3e48398e92de33e1a634521872dadf9a3e16f6
+DIST Django-2.0.13.tar.gz 7990057 BLAKE2B 8172d4ac3e74ce41403d3825ca102673e78cfc47c799a05de6543d3e06b69f97ce475b314d78d88226564cc2cafa1cbd1f6237232967ba15d88d94fa83514e1d SHA512 cae1977bec5b23475bb8b3b67444bf3b12edcd212db11e22e4d10456b1ae5d8dcc1734f1f07cb1e19dd39577684b03821cfc247174d687e29ea8fbed7b628727
 DIST Django-2.1.5.tar.gz 8612384 BLAKE2B 71396905dd4524f4ec8112d6c36967fcb381514eba6231b02bedf0f0a7cf9a164bb5d7df30bb4ae0dd8e77c4acd34ecd83d237713fbf58ca8b0db32446986044 SHA512 0a8c72e131867787d475feb0ccd7896fe2aefbbda60d85450fc5ce336eb1f1b7c77d7a17ba0a89e4bac84b7fc87f6c22d7afa356443958e30e958eeec7d3ee6d
+DIST Django-2.1.7.tar.gz 8608548 BLAKE2B c391fe2ed0fe9a4f4ef45cf828a0a85c16d5ede7c1bdc1ed5fae1185f04052290817900e97f95fa199425c344d91a9d32c7fb7ac8aec5d12152e7f8a39f8136f SHA512 bacbd52c834a14267588f7bcf57f52c246beb9971352e60eb780e28872884e0dd3701256dcd9600ae0faad29f42460391ea973e9fbb3338c2c08baf0d5ca2fe8
diff --git a/dev-python/django/django-1.11.20.ebuild b/dev-python/django/django-1.11.20.ebuild
new file mode 100644 (file)
index 0000000..e6b8db1
--- /dev/null
@@ -0,0 +1,112 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+WEBAPP_NO_AUTO_INSTALL="yes"
+
+inherit bash-completion-r1 distutils-r1 eutils eapi7-ver webapp
+
+MY_PN="Django"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
+SRC_URI="
+       https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz
+       mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
+       "
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc sqlite test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/pytz[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
+       test? (
+               $(python_gen_impl_dep sqlite)
+               dev-python/docutils[${PYTHON_USEDEP}]
+               dev-python/numpy[$(python_gen_usedep 'python*')]
+               dev-python/pillow[${PYTHON_USEDEP}]
+               dev-python/pyyaml[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               virtual/python-enum34[${PYTHON_USEDEP}]
+               )"
+
+S="${WORKDIR}/${MY_P}"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.9-bashcomp.patch
+)
+
+pkg_setup() {
+       webapp_pkg_setup
+}
+
+python_prepare_all() {
+       # Prevent d'loading in the doc build
+       sed -e '/^    "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       # Tests have non-standard assumptions about PYTHONPATH,
+       # and don't work with ${BUILD_DIR}/lib.
+       PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 --parallel 1 \
+               || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       newbashcomp extras/django_bash_completion ${PN}-admin
+       bashcomp_alias ${PN}-admin django-admin.py
+
+       if use doc; then
+               rm -fr docs/_build/html/_sources || die
+               local HTML_DOCS=( docs/_build/html/. )
+       fi
+
+       insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+       doins -r django/contrib/admin/static/admin/.
+       distutils-r1_python_install_all
+}
+
+src_install() {
+       distutils-r1_src_install
+       webapp_src_install
+}
+
+pkg_postinst() {
+       elog "Additional Backend support can be enabled via"
+       optfeature "MySQL backend support in python 2.7 only" dev-python/mysql-python
+       optfeature "MySQL backend support in python 2.7 - 3.4" dev-python/mysqlclient
+       optfeature "PostgreSQL backend support" dev-python/psycopg:2
+       echo ""
+       elog "Other features can be enhanced by"
+       optfeature "GEO Django" sci-libs/gdal[geos]
+       optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+       optfeature "ImageField Support" dev-python/pillow
+       optfeature "Password encryption" dev-python/bcrypt
+       optfeature "High-level abstractions for Django forms" dev-python/django-formtools
+       echo ""
+       elog "A copy of the admin media is available to webapp-config for installation in a"
+       elog "webroot, as well as the traditional location in python's site-packages dir"
+       elog "for easy development."
+       webapp_pkg_postinst
+}
diff --git a/dev-python/django/django-2.0.13.ebuild b/dev-python/django/django-2.0.13.ebuild
new file mode 100644 (file)
index 0000000..0761bad
--- /dev/null
@@ -0,0 +1,110 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+WEBAPP_NO_AUTO_INSTALL="yes"
+
+inherit bash-completion-r1 distutils-r1 eutils eapi7-ver webapp
+
+MY_PN="Django"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
+SRC_URI="
+       https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz
+       mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
+       "
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc sqlite test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/pytz[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
+       test? (
+               $(python_gen_impl_dep sqlite)
+               dev-python/docutils[${PYTHON_USEDEP}]
+               dev-python/numpy[${PYTHON_USEDEP}]
+               dev-python/pillow[${PYTHON_USEDEP}]
+               dev-python/pyyaml[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+       )"
+
+S="${WORKDIR}/${MY_P}"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.0.7-bashcomp.patch
+)
+
+pkg_setup() {
+       webapp_pkg_setup
+}
+
+python_prepare_all() {
+       # Prevent d'loading in the doc build
+       sed -e '/^    "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       # Tests have non-standard assumptions about PYTHONPATH,
+       # and don't work with ${BUILD_DIR}/lib.
+       PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 --parallel 1 \
+               || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       newbashcomp extras/django_bash_completion ${PN}-admin
+       bashcomp_alias ${PN}-admin django-admin.py
+
+       if use doc; then
+               rm -fr docs/_build/html/_sources || die
+               local HTML_DOCS=( docs/_build/html/. )
+       fi
+
+       insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+       doins -r django/contrib/admin/static/admin/.
+       distutils-r1_python_install_all
+}
+
+src_install() {
+       distutils-r1_src_install
+       webapp_src_install
+}
+
+pkg_postinst() {
+       elog "Additional Backend support can be enabled via"
+       optfeature "MySQL backend support" dev-python/mysqlclient
+       optfeature "PostgreSQL backend support" dev-python/psycopg:2
+       echo ""
+       elog "Other features can be enhanced by"
+       optfeature "GEO Django" sci-libs/gdal[geos]
+       optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+       optfeature "ImageField Support" dev-python/pillow
+       optfeature "Password encryption" dev-python/bcrypt
+       optfeature "High-level abstractions for Django forms" dev-python/django-formtools
+       echo ""
+       elog "A copy of the admin media is available to webapp-config for installation in a"
+       elog "webroot, as well as the traditional location in python's site-packages dir"
+       elog "for easy development."
+       webapp_pkg_postinst
+}
diff --git a/dev-python/django/django-2.1.7.ebuild b/dev-python/django/django-2.1.7.ebuild
new file mode 100644 (file)
index 0000000..fa86680
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+
+inherit bash-completion-r1 distutils-r1 eutils
+
+MY_PN="Django"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
+SRC_URI="https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc sqlite test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? (
+               $(python_gen_impl_dep sqlite)
+               dev-python/docutils[${PYTHON_USEDEP}]
+               dev-python/numpy[${PYTHON_USEDEP}]
+               dev-python/pillow[${PYTHON_USEDEP}]
+               dev-python/pyyaml[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+       )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.0.7-bashcomp.patch
+)
+
+python_prepare_all() {
+       # Prevent d'loading in the doc build
+       sed -e '/^    "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       # Tests have non-standard assumptions about PYTHONPATH,
+       # and don't work with ${BUILD_DIR}/lib.
+       PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 \
+               || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       newbashcomp extras/django_bash_completion ${PN}-admin
+       bashcomp_alias ${PN}-admin django-admin.py
+
+       if use doc; then
+               rm -fr docs/_build/html/_sources || die
+               local HTML_DOCS=( docs/_build/html/. )
+       fi
+
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       elog "Additional Backend support can be enabled via"
+       optfeature "MySQL backend support" dev-python/mysqlclient
+       optfeature "PostgreSQL backend support" dev-python/psycopg:2
+       echo ""
+       elog "Other features can be enhanced by"
+       optfeature "GEO Django" sci-libs/gdal[geos]
+       optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+       optfeature "ImageField Support" dev-python/pillow
+       optfeature "Password encryption" dev-python/bcrypt
+       optfeature "High-level abstractions for Django forms" dev-python/django-formtools
+}