dev-libs/skyutils: add libressl support
authorAnthony G. Basile <blueness@gentoo.org>
Sun, 26 Jun 2016 00:09:01 +0000 (20:09 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Sun, 26 Jun 2016 00:09:01 +0000 (20:09 -0400)
Package-Manager: portage-2.2.28

dev-libs/skyutils/skyutils-2.8-r3.ebuild [new file with mode: 0644]

diff --git a/dev-libs/skyutils/skyutils-2.8-r3.ebuild b/dev-libs/skyutils/skyutils-2.8-r3.ebuild
new file mode 100644 (file)
index 0000000..9078880
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="Library of assorted C utility functions"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage" # was "http://zekiller.skytech.org/coders_en.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl ssl"
+
+DEPEND="ssl? (
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+)"
+
+src_prepare() {
+       sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
+       epatch "${FILESDIR}"/${P}-libs.patch
+       eautoreconf
+}
+
+src_configure() {
+       append-flags -D_GNU_SOURCE
+       econf `use_enable ssl` || die "./configure failed"
+}
+
+src_install () {
+       emake DESTDIR="${D}" install || die "make install failed"
+       dodoc AUTHORS ChangeLog
+}