dev-go/go-tools: fix live ebuild for go-1.5 and newer
authorWilliam Hubbs <williamh@gentoo.org>
Sun, 23 Aug 2015 23:33:10 +0000 (18:33 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Sun, 23 Aug 2015 23:35:04 +0000 (18:35 -0500)
In Go 1.5, cover and vet have moved back to the main Go repository, so
the ones in this package are deprecated.

dev-go/go-tools/go-tools-9999.ebuild

index 3e1bc873aed2d6d50cc66ad00a89e625665860b8..63de13a85cc2398f73a507e308df0e0417b5a711 100644 (file)
@@ -83,8 +83,13 @@ src_install() {
        GOROOT="${T}/goroot" golang-build_src_install
        dobin bin/* "${T}/goroot/bin/godoc"
 
-       exeinto "$(go env GOTOOLDIR)"
-       exeopts -m0755 -p # preserve timestamps for bug 551486
-       doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/cover"
-       doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/vet"
+       if has_version '<dev-lang/go-1.5'; then
+               exeinto "$(go env GOTOOLDIR)"
+               exeopts -m0755 -p # preserve timestamps for bug 551486
+               doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/cover"
+               doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/vet"
+       else
+               rm "${D}"/usr/bin/{cover,vet} ||
+                       die "unable to remove cover and vet"
+       fi
 }