projects
/
portage.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a1a3532
)
Fix UnboundLocalError for catdir inside dblink.unmerge().
author
Zac Medico
<zmedico@gentoo.org>
Sat, 21 Aug 2010 22:16:10 +0000
(15:16 -0700)
committer
Zac Medico
<zmedico@gentoo.org>
Sat, 21 Aug 2010 22:16:10 +0000
(15:16 -0700)
pym/portage/dbapi/vartree.py
patch
|
blob
|
history
diff --git
a/pym/portage/dbapi/vartree.py
b/pym/portage/dbapi/vartree.py
index a804652bce5aaf6757812f9ed8deba49b2383999..f986c0a3c97046cf16565f5bbbdd30a7af46fef0 100644
(file)
--- a/
pym/portage/dbapi/vartree.py
+++ b/
pym/portage/dbapi/vartree.py
@@
-2175,6
+2175,7
@@
class dblink(object):
myebuildpath = None
ebuild_phase = "prerm"
log_path = None
+ catdir = None
mystuff = os.listdir(self.dbdir)
for x in mystuff:
if x.endswith(".ebuild"):
@@
-2345,7
+2346,7
@@
class dblink(object):
finally:
unlockdir(builddir_lock)
try:
- if not catdir_lock:
+ if
catdir and
not catdir_lock:
# Lock catdir for removal if empty.
catdir_lock = lockdir(catdir)
finally: