dev-python/cryptography: Fix libressl support
authorLuca Barbato <lu_zero@gentoo.org>
Sun, 26 Feb 2017 16:43:28 +0000 (16:43 +0000)
committerLuca Barbato <lu_zero@gentoo.org>
Sun, 26 Feb 2017 16:43:56 +0000 (16:43 +0000)
Package-Manager: portage-2.3.3

dev-python/cryptography/cryptography-1.7.2.ebuild
dev-python/cryptography/files/cryptography-1.7.2-libressl-2.5.1.patch [new file with mode: 0644]

index c8c7f9b25d72754eba06684a4831c06b0484b0ab..85f516caaf193b8e5d09b7e60ce9b17d88d1886e 100644 (file)
@@ -43,6 +43,7 @@ DEPEND="${RDEPEND}
        )"
 
 DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+PATCHES=( "${FILESDIR}"/${P}-libressl-2.5.1.patch )
 
 python_test() {
        distutils_install_for_testing
diff --git a/dev-python/cryptography/files/cryptography-1.7.2-libressl-2.5.1.patch b/dev-python/cryptography/files/cryptography-1.7.2-libressl-2.5.1.patch
new file mode 100644 (file)
index 0000000..38fce99
--- /dev/null
@@ -0,0 +1,16 @@
+diff -urN cryptography-1.7.2.orig/src/_cffi_src/openssl/x509_vfy.py cryptography-1.7.2/src/_cffi_src/openssl/x509_vfy.py
+--- cryptography-1.7.2.orig/src/_cffi_src/openssl/x509_vfy.py  2017-01-27 15:09:52.000000000 +0000
++++ cryptography-1.7.2/src/_cffi_src/openssl/x509_vfy.py       2017-02-26 15:15:09.889855740 +0000
+@@ -221,10 +221,12 @@
+ static const long X509_V_ERR_SUITE_B_INVALID_SIGNATURE_ALGORITHM = 0;
+ static const long X509_V_ERR_SUITE_B_LOS_NOT_ALLOWED = 0;
+ static const long X509_V_ERR_SUITE_B_CANNOT_SIGN_P_384_WITH_P_256 = 0;
++#ifndef X509_V_ERR_HOSTNAME_MISMATCH
+ static const long X509_V_ERR_HOSTNAME_MISMATCH = 0;
+ static const long X509_V_ERR_EMAIL_MISMATCH = 0;
+ static const long X509_V_ERR_IP_ADDRESS_MISMATCH = 0;
+ #endif
++#endif
+
+ /* OpenSSL 1.0.2beta2+ verification parameters */
+ #if CRYPTOGRAPHY_OPENSSL_102BETA2_OR_GREATER && \