dev-libs/antlr-c: Version bump to 3.5.2
authorJames Le Cuirot <chewi@gentoo.org>
Tue, 12 Jan 2016 23:22:20 +0000 (23:22 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Tue, 12 Jan 2016 23:23:08 +0000 (23:23 +0000)
Adds multilib support. This version also includes important fixes for
mysql-workbench. See bug #570600.

Package-Manager: portage-2.2.26

dev-libs/antlr-c/Manifest
dev-libs/antlr-c/antlr-c-3.5.2.ebuild [new file with mode: 0644]
dev-libs/antlr-c/antlr-c-3.5.ebuild [deleted file]
dev-libs/antlr-c/files/3.5-cflags.patch [moved from dev-libs/antlr-c/files/antlr-c-3.3-cflags.patch with 100% similarity]

index 7218aff345402e36564b08690a367288d02fd265..ec4fb21de7678e009c8a617650aa554b1ba1d248 100644 (file)
@@ -1 +1 @@
-DIST antlr-3.5.tar.gz 6791279 SHA256 6be17690f782c899cda68be812df5c40911aed057bf0192b0c37d2711cba8fc8 SHA512 a7014bc5d178add8a1f8e44a19ec60fed934f79f38fd702c7d7c3bb6a8c803492063911f86a445b696d10956f6f902144a5244046e83d70cffdc1717400c38a7 WHIRLPOOL c364d9ffac34de2e80a04233c73cab54b468eb958d924a305ccfc534587996edd4ee78a8fbb9416f2cad404dc43f44da9f9717e32e3f33da900c450c41a046ea
+DIST antlr-3.5.2.tar.gz 6927126 SHA256 529baf7d11f06b773543e25271c1a6e1735d2f8061f4866d1ea5c99a5d71ee1f SHA512 e2a0520093fb2a77dcd9d44f26a9fdd612dceaffb398c53b2b8cd29f4630830647ede29e8dd55b434cb2c165b0fd1d77968ec6e6de0798f14d9cdfd9e6fccd99 WHIRLPOOL a3a2bf81cc91a332725a4ce15dcccf10df5395b27a521656b1f3e80fed10197edc132fa2a8b9a259b2ee603320492b4b1f664692a967fdfdbb574d919b9aa20e
diff --git a/dev-libs/antlr-c/antlr-c-3.5.2.ebuild b/dev-libs/antlr-c/antlr-c-3.5.2.ebuild
new file mode 100644 (file)
index 0000000..3449cd4
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools multilib-minimal
+
+MY_PN="${PN%-c}"
+DESCRIPTION="The ANTLR3 C Runtime"
+HOMEPAGE="http://www.antlr3.org/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}3/archive/${PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug debugger doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen[dot] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}3-${PV}/runtime/C"
+PATCHES=( "${FILESDIR}/3.5-cflags.patch" )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/antlr3config.h )
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+       default
+       sed -i '/^QUIET/s/NO/YES/' doxyfile || die
+       eautoreconf
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       local econfargs=(
+               --enable-shared
+               $(use_enable debug debuginfo)
+               $(use_enable debugger antlrdebug)
+               $(use_enable static-libs static)
+       )
+
+       case "${ABI}" in
+               *64*) econfargs+=( --enable-64bit ) ;;
+               *) econfargs+=( --disable-64bit ) ;;
+       esac
+
+       econf "${econfargs[@]}"
+}
+
+src_compile() {
+       multilib-minimal_src_compile
+
+       if use doc; then
+               einfo "Generating API documentation ..."
+               cd "${S}" || die
+               doxygen -u doxyfile || die
+               doxygen doxyfile || die
+       fi
+}
+
+src_install() {
+       multilib-minimal_src_install
+       prune_libtool_files
+       use doc && dohtml -r "${S}/api/"
+}
diff --git a/dev-libs/antlr-c/antlr-c-3.5.ebuild b/dev-libs/antlr-c/antlr-c-3.5.ebuild
deleted file mode 100644 (file)
index 3ac3af3..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit autotools-utils eutils
-
-MY_P="antlr-${PV}"
-DESCRIPTION="The ANTLR3 C Runtime"
-HOMEPAGE="https://github.com/antlr/antlr3/tree/master/runtime/C"
-SRC_URI="https://github.com/antlr/antlr3/archive/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug debugger doc static-libs"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-S="${WORKDIR}/antlr3-${MY_P}/runtime/C"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-PATCHES=( "${FILESDIR}/${PN}-3.3-cflags.patch" )
-
-src_prepare() {
-       sed -i -e '/^QUIET/s/NO/YES/' doxyfile || die 'sed on doxyfile failed'
-
-       autotools-utils_src_prepare
-}
-
-src_configure() {
-       local myeconfargs=(
-               $(use_enable static-libs static)
-               $(use_enable debug debuginfo)
-               $(use_enable debugger antlrdebug)
-       )
-       if use amd64 || use ia64; then
-               myeconfargs+=( --enable-64bit )
-       else
-               myeconfargs+=( --disable-64bit )
-       fi
-
-       autotools-utils_src_configure
-}
-
-src_compile() {
-       autotools-utils_src_compile
-
-       if use doc; then
-               einfo "Generating documentation API ..."
-               doxygen -u doxyfile
-               doxygen doxyfile || die "doxygen failed"
-       fi
-}
-
-src_install() {
-       autotools-utils_src_install
-
-       if use doc; then
-               dohtml api/*
-       fi
-}