dev-python/pypy3: Inline deps and include dev-python/pycparser dep
authorMichał Górny <mgorny@gentoo.org>
Sat, 11 Nov 2017 15:04:22 +0000 (16:04 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 11 Nov 2017 15:07:28 +0000 (16:07 +0100)
Replace the autogenerated || dependency with an inlined version,
and include dev-python/pycparser in it when using CPython 2.7 (it is
built-in in dev-python/pypy, through CFFI).

dev-python/pypy3/pypy3-5.9.0.ebuild
dev-python/pypy3/pypy3-9999.ebuild

index 68ba1a3ef97cdd0812300045dd8cac9ad1a61ba4..d81c5775b403f72e6dedf722f42c2047a701b99b 100644 (file)
@@ -35,8 +35,16 @@ RDEPEND=">=sys-libs/zlib-1.1.3:0=
        )
        !dev-python/pypy3-bin:0"
 DEPEND="${RDEPEND}
-       low-memory? ( virtual/pypy:0 )
-       !low-memory? ( ${PYTHON_DEPS} )"
+       low-memory? ( virtual/pypy )
+       !low-memory? (
+               || (
+                       virtual/pypy
+                       (
+                               dev-lang/python:2.7
+                               dev-python/pycparser[python_targets_python2_7(-),python_single_target_python2_7(+)]
+                       )
+               )
+       )"
 #      doc? ( dev-python/sphinx )
 
 S="${WORKDIR}/${MY_P}-src"
index 92c2f84f5b09bfe176c8e2dc60014c49850972e9..5be752f1fc4cf654292a5b5889c8c3c9a12444de 100644 (file)
@@ -36,8 +36,16 @@ RDEPEND=">=sys-libs/zlib-1.1.3:0=
        )
        !dev-python/pypy3-bin:0"
 DEPEND="${RDEPEND}
-       low-memory? ( virtual/pypy:0 )
-       !low-memory? ( ${PYTHON_DEPS} )"
+       low-memory? ( virtual/pypy )
+       !low-memory? (
+               || (
+                       virtual/pypy
+                       (
+                               dev-lang/python:2.7
+                               dev-python/pycparser[python_targets_python2_7(-),python_single_target_python2_7(+)]
+                       )
+               )
+       )"
 #      doc? ( dev-python/sphinx )
 
 # Who would care about predictable directory names?