dev-python/rospkg: bump to 1.2.0.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 11 Dec 2019 13:58:34 +0000 (14:58 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 11 Dec 2019 15:26:22 +0000 (16:26 +0100)
Add py37

Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-python/rospkg/Manifest
dev-python/rospkg/rospkg-1.2.0.ebuild [new file with mode: 0644]
dev-python/rospkg/rospkg-9999.ebuild

index 5508d2e11caf3bcfee16238f1141117c2a046887..a12f2364d915690e072f7e1a97fbe8da6bce43f4 100644 (file)
@@ -1,2 +1,3 @@
 DIST rospkg-1.1.10.tar.gz 90434 BLAKE2B 1eb128d7e3f6d07e8309ecf5ea6c4340afcbb6f0618fd4628543c046003782750c5013c13ff2ed17018abc6efc6ce2042ccf2c6dccea8933be7045ddfe3f4522 SHA512 54b1b0ca4683b9388989501781239cf35873f2bf2028d176718f624999835b21e44f0cc5988624b37f7172d21f0c01aa336d35a884753c842098e558c37ac6c8
 DIST rospkg-1.1.9.tar.gz 90412 BLAKE2B 4cca7d1ebfcba495aafd766f0d720a6bc6e5aade0bff098d4a1cbab3b55c7a720de7d1f97edf806a93cc21eeda4cac86e844b5e3b23f85cbcb7b328fd07da222 SHA512 d33005e29313ba06959189f8f563361fd9523c2368855f260347b4c509d8b4053f74db3e2cf5986031653d647ded097f272f65d617da93e13cf77a906cb56ca6
+DIST rospkg-1.2.0.tar.gz 90516 BLAKE2B 0c1d993c70f0ad383ab457c846416a22b9adf9611704a918c3765659231846749228073ea04950ddfdbe13f7e51f87ce5d17c1488f995e846a6590a0f9549efd SHA512 f059259a38b8b2281496a69f8a55fdd31a11e91583babb82e574363c40c90221a4abb7c1d7a5ed6be3b2389ee6aaf08b4e016260c73dd779f8c7993e6eba78db
diff --git a/dev-python/rospkg/rospkg-1.2.0.ebuild b/dev-python/rospkg/rospkg-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..bb6a736
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SRC_URI=""
+       KEYWORDS=""
+       # Needed for tests
+       S="${WORKDIR}/${PN}"
+       EGIT_CHECKOUT_DIR="${S}"
+else
+       SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+       )"
+DEPEND="${RDEPEND} ${BDEPEND}
+       test? (
+               dev-python/coverage[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+       )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+python_test() {
+       nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}
index 4043929c6edfb5ffb7ca81f70d86f9fc4b153945..bb6a7366b4adda9ffc701ac5440ba111439db4e2 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy{,3} )
 
 SCM=""
 if [ "${PV#9999}" != "${PV}" ] ; then