dev-python/socketpool: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 7 Mar 2020 14:59:17 +0000 (15:59 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 7 Mar 2020 14:59:17 +0000 (15:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/socketpool/socketpool-0.5.3-r1.ebuild [deleted file]
dev-python/socketpool/socketpool-0.5.3.ebuild [deleted file]

diff --git a/dev-python/socketpool/socketpool-0.5.3-r1.ebuild b/dev-python/socketpool/socketpool-0.5.3-r1.ebuild
deleted file mode 100644 (file)
index e423b75..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A simple Python socket pool"
-HOMEPAGE="https://github.com/benoitc/socketpool/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-LICENSE="|| ( MIT public-domain )"
-SLOT="0"
-
-RDEPEND="$(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' 'python2*')"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.5.2-locale.patch )
-
-python_test() {
-       py.test tests || die
-}
-
-python_install_all() {
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
-       fi
-       distutils-r1_python_install_all
-
-       # package installs unneeded LICENSE files here
-       rm -rf "${ED}"/usr/socketpool || die
-}
diff --git a/dev-python/socketpool/socketpool-0.5.3.ebuild b/dev-python/socketpool/socketpool-0.5.3.ebuild
deleted file mode 100644 (file)
index 15d48d4..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="A simple Python socket pool"
-HOMEPAGE="https://github.com/benoitc/socketpool/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="amd64 arm ~arm64 ppc ppc64 s390 ~sh ~sparc x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-LICENSE="|| ( MIT public-domain )"
-SLOT="0"
-
-RDEPEND="$(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' 'python2*')"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.5.2-locale.patch )
-
-python_test() {
-       py.test tests || die
-}
-
-python_install_all() {
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
-       fi
-       distutils-r1_python_install_all
-
-       # package installs unneeded LICENSE files here
-       rm -rf "${ED}"/usr/socketpool || die
-}