games-emulation/mupen64plus-audio-sdl: Bump to 2.5.9
authorMichał Górny <mgorny@gentoo.org>
Sun, 15 Sep 2019 08:46:58 +0000 (10:46 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 15 Sep 2019 09:51:13 +0000 (11:51 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
games-emulation/mupen64plus-audio-sdl/Manifest
games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.9.ebuild [new file with mode: 0644]

index 079761aa8e69c79c4d44edc1ca5d5f86f355d3b3..aa7a496f84bc3e2a2e477585b3e4404cfa814654 100644 (file)
@@ -1 +1,2 @@
+DIST mupen64plus-audio-sdl-src-2.5.9.tar.gz 28884 BLAKE2B a32aeff100e86f610e3b514718c6a4a786c6f88911f8782dcbc9b8a2d238c31984e5d119e31533363d8f848bf840ff7350ba41dea70e716d50cce14f2398c836 SHA512 624f7061b4909a5de071fbb8cf6432fd4b6ad390ea3f7dc7ae7a874dc922afee55352e53d48fba43d45a3282e9382e6b5774814c2a7d9724e134a01188596ea9
 DIST mupen64plus-audio-sdl-src-2.5.tar.gz 26147 BLAKE2B bcd0c76d1e4fffb55940889c329574760101177c7cc48bb6ea9a361be01515ec15261bf1254a8c605db2ebf8166d323b43620e8f7c978cc79603be3ad537a191 SHA512 0c63e16449c40f15abdeed968383a218ed9876a92b2c15cbeb6554b20008d6d12996c0fd3bc1c502084791596b8535340596e95a11fe5d27576342740e76db6a
diff --git a/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.9.ebuild b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.9.ebuild
new file mode 100644 (file)
index 0000000..5b2611d
--- /dev/null
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${PN}-src-${PV}
+inherit toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL audio plugin"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libsamplerate oss speex"
+
+RDEPEND=">=games-emulation/mupen64plus-core-${PV}:0=
+       media-libs/libsdl2:0=[sound]
+       libsamplerate? ( media-libs/libsamplerate:0= )
+       speex? ( media-libs/speex:0= )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       default
+
+       # avoid implicitly appending CPU flags
+       sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+       MAKEARGS=(
+               # Note: please keep this in sync in all of mupen64plus-* packages
+
+               -C projects/unix
+
+               # this basically means: GNU userspace
+               UNAME=Linux
+
+               # verbose output
+               V=1
+
+               CROSS_COMPILE="${CHOST}-"
+               CC="$(tc-getCC)"
+               CXX="$(tc-getCXX)"
+               PKG_CONFIG="$(tc-getPKG_CONFIG)"
+               # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+               # so we can leave OPTFLAGS empty
+               OPTFLAGS=
+
+               # paths, some of them are used at compile time
+               PREFIX=/usr
+               LIBDIR=/usr/$(get_libdir)
+
+               # disable unwanted magic
+               LDCONFIG=:
+               INSTALL_STRIP_FLAG=
+
+               # Package-specific stuff
+
+               # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+               SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+               SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+               NO_SPEEX=$(usex speex 0 1)
+               NO_SRC=$(usex libsamplerate 0 1)
+               NO_OSS=$(usex oss 0 1)
+               # not packaged (https://github.com/nemomobile/libaudioresource)
+               USE_AUDIORESOURCE=0
+       )
+
+       use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+       use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+       emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+       emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+       dodoc RELEASE
+}