dev-python/Kivy: Remove old
authorDavid Seifert <soap@gentoo.org>
Fri, 27 Dec 2019 18:52:12 +0000 (19:52 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 27 Dec 2019 18:52:12 +0000 (19:52 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/Kivy/Kivy-1.10.0.ebuild [deleted file]
dev-python/Kivy/Kivy-1.9.1-r1.ebuild [deleted file]
dev-python/Kivy/Kivy-1.9.1.ebuild [deleted file]
dev-python/Kivy/Manifest
dev-python/Kivy/files/modplug-fix.patch [deleted file]

diff --git a/dev-python/Kivy/Kivy-1.10.0.ebuild b/dev-python/Kivy/Kivy-1.10.0.ebuild
deleted file mode 100644 (file)
index ccdd94c..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DESCRIPTION="Library for rapid development of hardware-accelerated multitouch applications"
-HOMEPAGE="https://kivy.org/"
-SRC_URI="https://github.com/kivy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cairo camera doc examples garden gstreamer +sdl spell test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/pillow[${PYTHON_USEDEP}]
-       cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
-       camera? ( media-libs/opencv:0/2.4[$(python_gen_usedep 'python2_7')] )
-       garden? ( dev-python/kivy-garden[${PYTHON_USEDEP}] )
-       gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )
-       sdl? ( media-libs/libsdl2
-               media-libs/sdl2-ttf
-               media-libs/sdl2-image
-               media-libs/sdl2-mixer )
-       !sdl? ( dev-python/pygame[${PYTHON_USEDEP}] )
-       spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       dev-python/cython[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${P,,}"
-
-PATCHES=(
-       "${FILESDIR}/modplug-fix.patch"
-)
-
-python_prepare_all() {
-#      sed -e '/data_files=/d' -i "${S}/setup.py" || die
-#      sed -e 's/PYTHON = python/PYTHON ?= python/' -i Makefile || die
-
-       export USE_SDL2=$(usex sdl 1 0)
-       export USE_GSTREAMER=$(usex gstreamer 1 0)
-       export KIVY_USE_SETUPTOOLS=1
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       esetup.py build_ext --inplace
-       esetup.py build
-}
-
-python_compile_all() {
-       use doc && emake html
-}
-
-python_test() {
-       emake test PYTHON="${PYTHON}"
-}
-
-python_install_all() {
-       use doc && HTML_DOCS=( doc/build/html/. )
-       if use examples; then
-               insinto "/usr/share/doc/${PF}/examples/${f}/"
-               doins "${S}/examples"/* "${S}/examples"/*/*
-       fi
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/Kivy/Kivy-1.9.1-r1.ebuild b/dev-python/Kivy/Kivy-1.9.1-r1.ebuild
deleted file mode 100644 (file)
index de15acb..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DESCRIPTION="Library for rapid development of hardware-accelerated multitouch applications"
-HOMEPAGE="https://kivy.org/"
-SRC_URI="https://pypi.io/packages/source/${PN:0:1}/${PN}/${P,,}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cairo camera doc examples garden gstreamer +sdl spell test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/pillow[${PYTHON_USEDEP}]
-       cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
-       camera? ( media-libs/opencv:0/2.4[$(python_gen_usedep 'python2_7')] )
-       garden? ( dev-python/kivy-garden[${PYTHON_USEDEP}] )
-       gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )
-       sdl? ( media-libs/libsdl2
-               media-libs/sdl2-ttf
-               media-libs/sdl2-image
-               media-libs/sdl2-mixer )
-       !sdl? ( dev-python/pygame[${PYTHON_USEDEP}] )
-       spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       dev-python/cython[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${P,,}"
-
-python_prepare_all() {
-       sed -e '/data_files=/d' -i "${S}/setup.py" || die
-       sed -e 's/PYTHON = python/PYTHON ?= python/' -i Makefile || die
-
-       export USE_SDL2=$(usex sdl 1 0)
-       export USE_GSTREAMER=$(usex gstreamer 1 0)
-       export KIVY_USE_SETUPTOOLS=1
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       esetup.py build_ext --inplace
-       esetup.py build
-}
-
-python_compile_all() {
-       use doc && emake html
-}
-
-python_test() {
-       emake test PYTHON="${PYTHON}"
-}
-
-python_install_all() {
-       use doc && HTML_DOCS=( doc/build/html/. )
-       if use examples; then
-               insinto "/usr/share/doc/${PF}/examples/${f}/"
-               doins "${S}/examples"/* "${S}/examples"/*/*
-       fi
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/Kivy/Kivy-1.9.1.ebuild b/dev-python/Kivy/Kivy-1.9.1.ebuild
deleted file mode 100644 (file)
index 7667522..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DESCRIPTION="Library for rapid development of hardware-accelerated multitouch applications"
-HOMEPAGE="https://kivy.org/"
-SRC_URI="https://pypi.io/packages/source/${PN:0:1}/${PN}/${P,,}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="cairo camera doc examples garden gstreamer +sdl spell test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/pillow[${PYTHON_USEDEP}]
-       cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
-       camera? ( media-libs/opencv:0/2.4[$(python_gen_usedep 'python2_7')] )
-       garden? ( dev-python/kivy-garden[${PYTHON_USEDEP}] )
-       gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )
-       sdl? ( media-libs/libsdl2
-               media-libs/sdl2-ttf
-               media-libs/sdl2-image
-               media-libs/sdl2-mixer )
-       !sdl? ( dev-python/pygame[${PYTHON_USEDEP}] )
-       spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       dev-python/cython[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${P,,}"
-
-python_prepare_all() {
-       sed -e '/data_files=/d' -i "${S}/setup.py" || die
-       sed -e 's/PYTHON = python/PYTHON ?= python/' -i Makefile || die
-
-       export USE_SDL2=$(usex sdl 1 0)
-       export USE_GSTREAMER=$(usex gstreamer 1 0)
-       export KIVY_USE_SETUPTOOLS=1
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       esetup.py build_ext --inplace
-       esetup.py build
-}
-
-python_compile_all() {
-       use doc && emake html
-}
-
-python_test() {
-       emake test PYTHON="${PYTHON}"
-}
-
-python_install_all() {
-       use doc && HTML_DOCS=( doc/build/html/. )
-       use examples && EXAMPLES=( examples )
-       distutils-r1_python_install_all
-}
index 2956c4e2c16b8236dda520160082b72c24704138..5fc86976a87a0f9b9efae91d67337581eaa4b5df 100644 (file)
@@ -1,3 +1 @@
-DIST Kivy-1.10.0.tar.gz 24266702 BLAKE2B 3f1dab7c69e322d5856d1772d0902eaf5d4598957df1573e0c617ca872afa446797266f1ecd4a99da81bc7dcc40a051294d96c11e51a7fe2c505224bf0edaa42 SHA512 8049c92407e464558ecff913ff076c1b8f125b85a35b9eba64af49b35df545402ec2bac907ee545265a368b8cdbb33e02d74429dce13c53dd6feac735ace9cb4
 DIST Kivy-1.10.1.tar.gz 24318169 BLAKE2B 3032034717ad580af437eb280ad8474f057e1ab9f797edf3358db1073eda6e65ee8765862e39e77818debdf0a2a972ce3701b305ddfba307d9a8bfe2ce8edbc5 SHA512 2208e1a148dd1a7c507336419e7388de87d2ab340db055e09fce99837d50639e2e38f275e383503e5bdfc4b9d3def8176d758a80bf3455467604a4219c19d642
-DIST kivy-1.9.1.tar.gz 16363833 BLAKE2B 1f81ab0688e9ddc617da5e7d56523568e396f010587c971285996ca5544367a4f63bb6493f279ea66f6606b2808394614c25a96e97018ef0ae1e70d74eb9cd7e SHA512 1ae3ff3979a89e41c0af6493b7523835c1d01ee36fcd524f15d329b8fa875c6ca9bd25db3a844597fbc5370ff86b55ce177d3e66cc169223b02eb114c88c9989
diff --git a/dev-python/Kivy/files/modplug-fix.patch b/dev-python/Kivy/files/modplug-fix.patch
deleted file mode 100644 (file)
index 18abe6e..0000000
+++ /dev/null
@@ -1,109 +0,0 @@
-From 3b85f3e1c292b3f6c3f226490f52a2ab78251730 Mon Sep 17 00:00:00 2001
-From: Terje Skjaeveland <terje.skjaeveland@gmail.com>
-Date: Sun, 29 Oct 2017 12:35:46 +0100
-Subject: [PATCH] audio_sdl2: Update for mixer v2.0.2 support
-
-Flags MIX_INIT_MODPLUG was removed, and MIX_INIT_FLUIDSYNTH was
-renamed to MIX_INIT_MID.
----
- kivy/core/audio/audio_sdl2.pyx | 45 +++++++++++++++++++++++++++++-------------
- kivy/lib/sdl2.pxi              |  4 ++--
- 2 files changed, 33 insertions(+), 16 deletions(-)
-
-diff --git a/kivy/core/audio/audio_sdl2.pyx b/kivy/core/audio/audio_sdl2.pyx
-index 2ab569fe60..c6f26be5c8 100644
---- a/kivy/core/audio/audio_sdl2.pyx
-+++ b/kivy/core/audio/audio_sdl2.pyx
-@@ -15,9 +15,23 @@ Depending the compilation of SDL2 mixer and/or installed libraries:
- * ogg since 1.9.1 (mixer needs libvorbis/libogg)
- * flac since 1.9.1 (mixer needs libflac)
- * mp3 since 1.9.1 (mixer needs libsmpeg/libmad; only use mad for GPL apps)
-+  * Since 1.10.1 + mixer 2.0.2, mpg123 can also be used
- * sequenced formats since 1.9.1 (midi, mod, s3m, etc. Mixer needs
-   libmodplug or libmikmod)
-+.. Note::
-+
-+    Sequenced format support changed with mixer v2.0.2. If mixer is
-+    linked with one of libmodplug or libmikmod, format support for
-+    both libraries is assumed. This will work perfectly with formats
-+    upported by both libraries, but if you were to try to load an
-+    obscure format (like `apun` file with mikmod only), it will fail.
-+
-+    * Kivy <= 1.10.0: will fail to build with mixer >= 2.0.2
-+      will report correct format support with < 2.0.2
-+    * Kivy >= 1.10.1: will build with old and new mixer, and
-+      will "guesstimate" sequenced format support
-+
- .. Warning::
-     Sequenced formats use the SDL2 Mixer music channel, you can only play
-@@ -57,8 +71,13 @@ cdef mix_init():
-         mix_is_init = -1
-         return 0
-+    # In mixer 2.0.2, MIX_INIT_MODPLUG is now implied by MIX_INIT_MOD,
-+    # and MIX_INIT_FLUIDSYNTH was renamed to MIX_INIT_MID. In previous
-+    # versions, we requested both _MODPLUG and _MOD + _FLUIDSYNTH.
-+    # 0x20 used to be MIX_INIT_FLUIDSYNTH, now MIX_INIT_MID
-+    # 0x4  used to be MIX_INIT_MODPLUG before 2.0.2
-     want_flags = MIX_INIT_FLAC | MIX_INIT_OGG | MIX_INIT_MP3
--    want_flags |= MIX_INIT_MOD | MIX_INIT_MODPLUG | MIX_INIT_FLUIDSYNTH
-+    want_flags |= MIX_INIT_MOD | 0x20 | 0x4
-     mix_flags = Mix_Init(want_flags)
-@@ -244,25 +263,23 @@ class MusicSDL2(Sound):
-     @staticmethod
-     def extensions():
-         mix_init()
-+        # FIXME: this should probably evolve to use the new has_music()
-+        #        interface to determine format support
-         # Assume native midi support (defaults to enabled), but may use
-         # modplug, fluidsynth or timidity in reality. It may also be
-         # disabled completely, in which case loading it will fail
-         extensions = set(['mid', 'midi'])
--        # libmodplug, may be incomplete
--        if mix_flags & MIX_INIT_MODPLUG:
--            extensions.update(['669', 'abc', 'amf', 'ams', 'dbm', 'dmf',
--                               'dsm', 'far', 'it', 'j2b', 'mdl', 'med',
--                               'mod', 'mt2', 'mtm', 'okt', 'pat', 'psm',
--                               'ptm', 's3m', 'stm', 'ult', 'umx', 'xm'])
--
--        # libmikmod, may be incomplete
--        if mix_flags & MIX_INIT_MOD:
--            extensions.update(['669', 'amf', 'apun', 'dsm', 'far', 'gdm',
--                               'gt2', 'it',  'med', 'mod', 'mtm', 'okt',
--                               's3m', 'stm', 'stx', 'ult', 'umx', 'uni',
--                               'xm'])
-+        # libmodplug and libmikmod, may be incomplete.
-+        # 0x4 is for mixer < 2.0.2, MIX_INIT_MODPLUG
-+        if mix_flags & (MIX_INIT_MOD | 0x4):
-+            extensions.update(['669', 'abc', 'amf', 'ams', 'apun', 'dbm',
-+                               'dmf', 'dsm', 'far', 'gdm', 'it',   'j2b',
-+                               'mdl', 'med', 'mod', 'mt2', 'mtm',  'okt',
-+                               'pat', 'psm', 'ptm', 's3m', 'stm',  'stx',
-+                               'ult', 'umx', 'uni', 'xm'])
-+
-         return list(extensions)
-     def __init__(self, **kwargs):
-diff --git a/kivy/lib/sdl2.pxi b/kivy/lib/sdl2.pxi
-index 07d055c903..ad62ce8023 100644
---- a/kivy/lib/sdl2.pxi
-+++ b/kivy/lib/sdl2.pxi
-@@ -881,10 +881,10 @@ cdef extern from "SDL_mixer.h":
-     ctypedef enum MIX_InitFlags:
-         MIX_INIT_FLAC        = 0x00000001
-         MIX_INIT_MOD         = 0x00000002
--        MIX_INIT_MODPLUG     = 0x00000004
-+        MIX_INIT_MODPLUG     = 0x00000004 # Removed in mixer 2.0.2
-         MIX_INIT_MP3         = 0x00000008
-         MIX_INIT_OGG         = 0x00000010
--        MIX_INIT_FLUIDSYNTH  = 0x00000020
-+        MIX_INIT_MID         = 0x00000020 # Previously _FLUIDSYNTH
-     cdef int MIX_MAX_VOLUME