dev-python/hyperlink: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 08:38:36 +0000 (10:38 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 08:38:36 +0000 (10:38 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/hyperlink/hyperlink-19.0.0.ebuild

index 63b5855ee1207c79f62d6747a9fb3f4e794266af..4457f97f42f9cbda8d8efbcf22bef3a71b80b65b 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
 
 inherit distutils-r1
 
@@ -16,7 +16,5 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd6
 
 RDEPEND="
        dev-python/idna[${PYTHON_USEDEP}]"
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]"
 
 distutils_enable_tests pytest