dev-python/enaml: Clean old versions up
authorMichał Górny <mgorny@gentoo.org>
Tue, 2 May 2017 09:06:04 +0000 (11:06 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 2 May 2017 09:47:59 +0000 (11:47 +0200)
dev-python/enaml/Manifest
dev-python/enaml/enaml-0.6.8-r1.ebuild [deleted file]

index 480e0f8de1db286fd41646d991b0e2b7b59bbe58..03fa00865f5e25afae4486b681d9360cf3fa6e41 100644 (file)
@@ -1,2 +1 @@
-DIST enaml-0.6.8.tar.gz 4550240 SHA256 e0f3f5775bfd471b9ca748a547cde1b9b129e0e43f1b6adbcde6fcdcbbb18a9f SHA512 8942ae1f44aee97acc1813e684534ce982fcc48090a9295e95c56a8bbc2063a94c2561ff0752cb5ff9f1f08b7ebaa44bb3b16ea78cbb0821efdcb56f3cf72446 WHIRLPOOL d1d912cb62f3b33c848d89ed9e8f2bb4e03d5f9732903f7bd8180ed58cbf80993600b629e7753909c4d599db74d1d369a59b5dc568e2cb46773e579914e213bc
 DIST enaml-0.9.8.tar.gz 1455642 SHA256 c646f12dc7928555f2f24a10706c0d668b11a5e63e4b878dcb267247bf22a1d5 SHA512 e9b88d1fbb9e82564d3a865f74685b1b1f8b8918e29dd4d7ce7d6b4b2e6d386c6388e99f9bf0adb02fb9277a57519f8502a33bd6e0548fd1a4d52d0a4b33cf02 WHIRLPOOL f9c6874f7fec569acdbf74c5cdd24c6189506980ca65028c3ea53ed076338a5edea6b19d018d19b8662385b058d9c96c7e36239a1f86d8c1cdcada559f49bfd8
diff --git a/dev-python/enaml/enaml-0.6.8-r1.ebuild b/dev-python/enaml/enaml-0.6.8-r1.ebuild
deleted file mode 100644 (file)
index 7cbe391..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Enthought Tool Suite: framework for writing declarative interfaces"
-HOMEPAGE="http://code.enthought.com/projects/enaml/ https://pypi.python.org/pypi/enaml"
-SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="
-       dev-python/casuarius[${PYTHON_USEDEP}]
-       dev-python/ply[${PYTHON_USEDEP}]
-       dev-python/traits[${PYTHON_USEDEP}]
-       || (
-               dev-python/wxpython:*[${PYTHON_USEDEP}] \
-               dev-python/PyQt4[${PYTHON_USEDEP}] \
-               dev-python/pyside[${PYTHON_USEDEP}] )"
-
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/python-dateutil[${PYTHON_USEDEP}]
-               dev-python/wxpython[${PYTHON_USEDEP}]
-               dev-python/python-dateutil[${PYTHON_USEDEP}]
-               dev-python/pyside[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # crash doc and gone upstream (> 0.2.0)
-       sed -i -e '/enthought.debug.api/d' enamldoc/sphinx_ext.py || die
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       export ETS_TOOLKIT=qt4
-       export QT_API=pyside
-       VIRTUALX_COMMAND="nosetests -v" virtualmake
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-       use examples && local EXAMPLES=( examples/. )
-       distutils-r1_python_install_all
-}