media-libs/gstreamer: remove old
authorMart Raudsepp <leio@gentoo.org>
Tue, 5 Feb 2019 23:56:13 +0000 (01:56 +0200)
committerMart Raudsepp <leio@gentoo.org>
Tue, 5 Feb 2019 23:56:39 +0000 (01:56 +0200)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-libs/gstreamer/Manifest
media-libs/gstreamer/gstreamer-1.14.1.ebuild [deleted file]

index c2ba6ccfc536b65dfd5a4c726555f68952b1cdc2..f7da93ed8b8c6849459a9a9218f7c6b0f8edd3d2 100644 (file)
@@ -1,3 +1,2 @@
 DIST gstreamer-0.10.36.tar.xz 3025876 BLAKE2B f0f70f483e8ccb2a294fb3bc8b51aac089f5e76522249b64e3e60e7b488a9e03b9300617e2c137bdcc0e3e61668b7b203e899f270f004e2dfcee0927fa7dfc3c SHA512 7468abb578398681d2adb0e9bbc9ee8ae25aaef72369d45a66ada6c67d1759afdce606cb32e68d9e30ae813196bdfef3d4d33202bc77839cc1fbf5fc436c1bd8
-DIST gstreamer-1.14.1.tar.xz 3252440 BLAKE2B c2142621b126926dd9ec886f0478154b3f0d9b7adebc6169200b8bc7e4cd089dfe77cab2b436bf3c74cbcae5f84c95afbd05ba282d0afe3e8e226e6bc0f33e33 SHA512 9cf16d79774293dd7fa10c08f6628b83f4e77f0386bebbfd47ded0498e4abd48eee1aee164af53d59fbea2d395e42eb5a12ef4b8f631bc4fd5d4f69545191f9b
 DIST gstreamer-1.14.4.tar.xz 3264324 BLAKE2B d51febcd7c317964a09dadb4d3bd3ee7a60ac38bef28cdd7d42f49a7b710d6f6180ca7edee1765c8d146f7e3e852e93d0d5f69962089a653cfc3e6bd4ab42f89 SHA512 7ece9f01d40df7c8358482eac94536c5e15261e9568962008e2029e1ee1b3ebb220d2e4802ed1c81c40d897576fafe52234065e273724bfb4df3a3ddf2711abe
diff --git a/media-libs/gstreamer/gstreamer-1.14.1.ebuild b/media-libs/gstreamer/gstreamer-1.14.1.ebuild
deleted file mode 100644 (file)
index efe3f1a..0000000
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit bash-completion-r1 ltprune multilib-minimal pax-utils
-
-DESCRIPTION="Open source multimedia framework"
-HOMEPAGE="https://gstreamer.freedesktop.org/"
-SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="LGPL-2+"
-SLOT="1.0"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="+caps +introspection nls +orc test unwind"
-
-RDEPEND="
-       >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
-       caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
-       introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
-       unwind? (
-               >=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
-               dev-libs/elfutils[${MULTILIB_USEDEP}]
-       )
-       !<media-libs/gst-plugins-bad-1.13.1:1.0
-"
-DEPEND="${RDEPEND}
-       >=dev-util/gtk-doc-am-1.12
-       sys-devel/bison
-       sys-devel/flex
-       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
-       nls? ( sys-devel/gettext )
-"
-# gtk-doc-am to install API docs
-
-src_configure() {
-       if [[ ${CHOST} == *-interix* ]] ; then
-               export ac_cv_lib_dl_dladdr=no
-               export ac_cv_func_poll=no
-       fi
-       if [[ ${CHOST} == powerpc-apple-darwin* ]] ; then
-               # GCC groks this, but then refers to an implementation (___multi3,
-               # ___udivti3) that don't exist (at least I can't find it), so force
-               # this one to be off, such that we use 2x64bit emulation code.
-               export gst_cv_uint128_t=no
-       fi
-
-       multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
-       local completiondir=$(get_bashcompdir)
-       # Set 'libexecdir' to ABI-specific location for the library spawns
-       # helpers from there.
-       # Disable static archives and examples to speed up build time
-       # Disable debug, as it only affects -g passing (debugging symbols), this must done through make.conf in gentoo
-       local myconf=(
-               --libexecdir="${EPREFIX}"/usr/$(get_libdir)
-               --disable-benchmarks
-               --disable-debug
-               --disable-examples
-               --disable-static
-               --disable-valgrind
-               --enable-check
-               $(use_with unwind)
-               $(use_with unwind dw)
-               $(multilib_native_use_enable introspection)
-               $(use_enable nls)
-               $(use_enable test tests)
-               --with-bash-completion-dir="${completiondir%/*}"
-               --with-package-name="GStreamer ebuild for Gentoo"
-               --with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer"
-       )
-
-       if use caps ; then
-               myconf+=( --with-ptp-helper-permissions=capabilities )
-       else
-               myconf+=(
-                       --with-ptp-helper-permissions=setuid-root
-                       --with-ptp-helper-setuid-user=nobody
-                       --with-ptp-helper-setuid-group=nobody
-               )
-       fi
-
-       ECONF_SOURCE="${S}" econf "${myconf[@]}"
-
-       if multilib_is_native_abi; then
-               local x
-               for x in gst libs plugins; do
-                       ln -s "${S}"/docs/${x}/html docs/${x}/html || die
-               done
-       fi
-}
-
-multilib_src_install() {
-       # can't do "default", we want to install docs in multilib_src_install_all
-       emake DESTDIR="${D}" install
-
-       # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
-       use orc && pax-mark -m "${ED}usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
-}
-
-multilib_src_install_all() {
-       DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
-       einstalldocs
-       prune_libtool_files --modules
-
-       # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
-       use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}"
-}