sys-apps/roccat-tools: Make lua finder happy...
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 24 Jul 2019 05:45:51 +0000 (07:45 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 24 Jul 2019 05:47:49 +0000 (07:47 +0200)
Thanks-to: Attila Tóth <atoth@atoth.sote.hu>
Closes: https://bugs.gentoo.org/690532
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild

index 36aaaeefd2b921a919836c03d4b7719fecb50876..1f81be7eaa3408af098c90f6daca84427825d93c 100644 (file)
@@ -42,6 +42,8 @@ IUSE_INPUT_DEVICES=(
 
 IUSE="${IUSE_INPUT_DEVICES[@]}"
 
+LUA_DEPEND="|| ( dev-lang/lua:5.1 dev-lang/lua:0 )"
+
 RDEPEND="
        dev-libs/dbus-glib
        dev-libs/glib:2
@@ -52,9 +54,9 @@ RDEPEND="
        x11-libs/libX11
        virtual/libgudev:=
        virtual/libusb:1
-       input_devices_roccat_ryosmk? ( || ( dev-lang/lua:5.1 dev-lang/lua:0 ) )
-       input_devices_roccat_ryosmkfx? ( || ( dev-lang/lua:5.1 dev-lang/lua:0 ) )
-       input_devices_roccat_ryostkl? ( || ( dev-lang/lua:5.1 dev-lang/lua:0 ) )
+       input_devices_roccat_ryosmk? ( ${LUA_DEPEND} )
+       input_devices_roccat_ryosmkfx? ( ${LUA_DEPEND} )
+       input_devices_roccat_ryostkl? ( ${LUA_DEPEND} )
 "
 
 DEPEND="
@@ -82,6 +84,20 @@ src_configure() {
                -DDEVICES="${USED_MODELS/;/}"
                -DUDEVDIR="${EPREFIX}$(get_udevdir)/rules.d"
        )
+
+       local lua_use=(
+               input_devices_roccat_ryosmk
+               input_devices_roccat_ryosmkfx
+               input_devices_roccat_ryostkl
+       )
+       local luse
+       for luse in ${lua_use[@]} ; do
+               if use ${luse} ; then
+                       mycmakeargs+=( -DWITH_LUA="5.1" )
+                       break
+               fi
+       done
+
        cmake-utils_src_configure
 }