dev-libs/weston: Remove the ability to select --with-cairo={gl,glesv2}.
authorMatt Turner <mattst88@gentoo.org>
Sun, 30 Aug 2015 19:49:27 +0000 (12:49 -0700)
committerMatt Turner <mattst88@gentoo.org>
Tue, 22 Sep 2015 16:32:47 +0000 (09:32 -0700)
Bug: https://bugs.gentoo.org/549912

dev-libs/weston/weston-9999.ebuild
profiles/base/package.use.mask

index 0c32e69a231c42fa62f7a32386de487abacc1b90..f4e816e07713f66302dd78022ef33267a2cc31b7 100644 (file)
@@ -27,15 +27,13 @@ fi
 
 LICENSE="MIT CC-BY-SA-3.0"
 SLOT="0"
-IUSE="colord dbus +drm +egl editor examples fbdev gles2 headless ivi +opengl rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor +X xwayland"
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor +X xwayland"
 
 REQUIRED_USE="
-       drm? ( egl )
-       egl? ( || ( gles2 opengl ) )
-       gles2? ( !opengl )
+       drm? ( gles2 )
        screen-sharing? ( rdp )
        test? ( X )
-       wayland-compositor? ( egl )
+       wayland-compositor? ( gles2 )
 "
 
 RDEPEND="
@@ -45,7 +43,7 @@ RDEPEND="
        media-libs/libpng:0=
        media-libs/libwebp:0=
        virtual/jpeg
-       >=x11-libs/cairo-1.11.3[gles2(-)?,opengl?]
+       >=x11-libs/cairo-1.11.3
        >=x11-libs/libdrm-2.4.30
        x11-libs/libxkbcommon
        x11-libs/pixman
@@ -61,15 +59,9 @@ RDEPEND="
                >=sys-libs/mtdev-1.1.0
                >=virtual/udev-136
        )
-       egl? (
-               media-libs/mesa[gles2,wayland]
-       )
        editor? ( x11-libs/pango )
        gles2? (
-               media-libs/mesa[wayland]
-       )
-       opengl? (
-               media-libs/mesa[wayland]
+               media-libs/mesa[gles2,wayland]
        )
        rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
        rpi? (
@@ -105,21 +97,13 @@ src_prepare() {
 
 src_configure() {
        local myconf
-       if use examples || use gles2 || use test; then
-               myconf="--enable-simple-clients
-                       $(use_enable egl simple-egl-clients)"
+       if use examples || use test; then
+               myconf="--enable-simple-clients"
        else
-               myconf="--disable-simple-clients
-                       --disable-simple-egl-clients"
+               myconf="--disable-simple-clients"
        fi
 
-       if use gles2; then
-               myconf+=" --with-cairo=glesv2"
-       elif use opengl; then
-               myconf+=" --with-cairo=gl"
-       else
-               myconf+=" --with-cairo=image"
-       fi
+       myconf+=" --with-cairo=image --disable-simple-egl-clients"
 
        econf \
                $(use_enable examples demo-clients-install) \
@@ -134,7 +118,7 @@ src_configure() {
                $(use_enable X x11-compositor) \
                $(use_enable launch weston-launch) \
                $(use_enable colord) \
-               $(use_enable egl) \
+               $(use_enable gles2 egl) \
                $(use_enable unwind libunwind) \
                $(use_enable resize-optimization) \
                $(use_enable screen-sharing) \
index dedbee4f81ffa41ad1063c5e58e06a9f6e604fa6..6ebc30da3be2d18ca2878c02fd6f1f020d9033be 100644 (file)
@@ -469,7 +469,8 @@ media-sound/clementine ios
 # Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (13 Jul 2013)
 # GL/GLES support in cairo is mutually exclusive, bug #428770.
 x11-libs/cairo gles2
-dev-libs/weston gles2 rpi
+dev-libs/weston rpi
+<dev-libs/weston-9999 gles2
 
 # Alexis Ballier <aballier@gentoo.org> (03 Jul 2013)
 # The idea behind using libunwind there is to avoid needing to link to libgcc_s