media-tv/v4l-utils: patch for -fno-common bug
authorAndrey Utkin <andrey_utkin@gentoo.org>
Fri, 20 Mar 2020 22:58:24 +0000 (22:58 +0000)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Fri, 20 Mar 2020 23:06:40 +0000 (23:06 +0000)
Reused the patch already used for media-libs/libv4l.

Applied to ebuilds 1.16.6 (last stable) and 1.18.0 (not stabilized).
No revision bump as this is a trivial build failure treatment.

Bug: https://bugs.gentoo.org/706834
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
media-tv/v4l-utils/files/v4l-utils-1.16.6-gcc10-fno-common.patch [new file with mode: 0644]
media-tv/v4l-utils/v4l-utils-1.16.6.ebuild
media-tv/v4l-utils/v4l-utils-1.18.0.ebuild

diff --git a/media-tv/v4l-utils/files/v4l-utils-1.16.6-gcc10-fno-common.patch b/media-tv/v4l-utils/files/v4l-utils-1.16.6-gcc10-fno-common.patch
new file mode 100644 (file)
index 0000000..33855c6
--- /dev/null
@@ -0,0 +1,68 @@
+From afb123618b087f3ca2305b84fb004624662e52f0 Mon Sep 17 00:00:00 2001
+From: David Seifert <soap@gentoo.org>
+Date: Wed, 26 Feb 2020 11:07:29 +0100
+Subject: Fix GCC 10 / -fno-common
+
+* GCC 10 switches its default symbol emission mode
+  to cause linker errors when an object is defined
+  more than once.
+
+Bug: https://bugs.gentoo.org/706756
+Signed-off-by: David Seifert <soap@gentoo.org>
+Signed-off-by: Hans Verkuil <hverkuil-cisco@xs4all.nl>
+---
+ lib/include/libdvbv5/desc_t2_delivery.h |  2 +-
+ lib/libdvbv5/dvb-v5.h                   | 26 +++++++++++++-------------
+ 2 files changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/lib/include/libdvbv5/desc_t2_delivery.h b/lib/include/libdvbv5/desc_t2_delivery.h
+index 93594b76..8c11fa9a 100644
+--- a/lib/include/libdvbv5/desc_t2_delivery.h
++++ b/lib/include/libdvbv5/desc_t2_delivery.h
+@@ -215,7 +215,7 @@ extern const unsigned dvbt2_transmission_mode[];
+  * @brief converts from internal representation to string the SISO_MISO
+  *      field of dvb_desc_t2_delivery:SISO_MISO field.
+  */
+-const char *siso_miso[4];
++extern const char *siso_miso[4];
+ #ifdef __cplusplus
+ }
+diff --git a/lib/libdvbv5/dvb-v5.h b/lib/libdvbv5/dvb-v5.h
+index 45aaddda..3540bac1 100644
+--- a/lib/libdvbv5/dvb-v5.h
++++ b/lib/libdvbv5/dvb-v5.h
+@@ -14,17 +14,17 @@ struct fe_status_name {
+       char *name;
+ };
+ extern struct fe_status_name fe_status_name[8];
+-const char *fe_code_rate_name[14];
+-const char *fe_modulation_name[15];
+-const char *fe_transmission_mode_name[10];
+-const unsigned fe_bandwidth_name[8];
+-const char *fe_guard_interval_name[12];
+-const char *fe_hierarchy_name[6];
+-const char *fe_voltage_name[4];
+-const char *fe_tone_name[3];
+-const char *fe_inversion_name[4];
+-const char *fe_pilot_name[4];
+-const char *fe_rolloff_name[5];
+-const char *dvb_v5_name[72];
+-const char *delivery_system_name[20];
++extern const char *fe_code_rate_name[14];
++extern const char *fe_modulation_name[15];
++extern const char *fe_transmission_mode_name[10];
++extern const unsigned fe_bandwidth_name[8];
++extern const char *fe_guard_interval_name[12];
++extern const char *fe_hierarchy_name[6];
++extern const char *fe_voltage_name[4];
++extern const char *fe_tone_name[3];
++extern const char *fe_inversion_name[4];
++extern const char *fe_pilot_name[4];
++extern const char *fe_rolloff_name[5];
++extern const char *dvb_v5_name[72];
++extern const char *delivery_system_name[20];
+ #endif
+-- 
+cgit v1.2.1
+
index 72e4deafa29c156c1433e45a3b497e010e1fc03c..5b1881372f238ede8ba711d7c3a53f884f95a3a5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -31,6 +31,8 @@ BDEPEND="
        sys-devel/gettext
        virtual/pkgconfig"
 
+PATCHES=( "${FILESDIR}"/${PN}-1.16.6-gcc10-fno-common.patch )
+
 src_configure() {
        if use qt5; then
                append-cxxflags -std=c++11
index ec17de13f97c2ce2b166a707a0db860137910988..777a22b6a5528b86cd16eec796d12bfcc9ec702e 100644 (file)
@@ -31,6 +31,8 @@ BDEPEND="
        sys-devel/gettext
        virtual/pkgconfig"
 
+PATCHES=( "${FILESDIR}"/${PN}-1.16.6-gcc10-fno-common.patch )
+
 src_configure() {
        if use qt5; then
                append-cxxflags -std=c++11